SVERWEIS mit mehreren Bedingungen

Bild

Betrifft: SVERWEIS mit mehreren Bedingungen
von: Ralf
Geschrieben am: 19.08.2015 12:19:43

Hallo Leute,
ich habe mal wieder ein kleines Problem. Ich möchte in einer Zelle die zwei darüber liegenden Zellen mit der WENN und SVERWEIS Funktion abfragen und mir einen Wert ausgeben lassen. Das klappt auch schon. Wenn nun aber ein "K" in einer der Zellen steht soll SVERWEIS einen anderen Bereich abgleichen. Ich hab ein Beispiel hochgeladen welches die Problematik hoffentlich verständlich macht. Das ganze soll ein Dienstplan werden.
https://www.herber.de/bbs/user/99684.xlsx
Danke Ralf

Bild

Betrifft: AW: SVERWEIS mit mehreren Bedingungen
von: Daniel
Geschrieben am: 19.08.2015 12:35:54
Hi
du kannst die Wenn-Funktion auch auf einzelne Parameter anwenden:
hier mal für dein Beipsiel mit N4 und N5:
=Wenn(N4&N5="";"";SVerweis(Wenn(N5="";N4;N5);Tabelle1!$A$2:$B$40;2;0))
das funktioniert natürlich auch mit der Matrix für den SVerweis:
=Wenn(N4&N5="";"";SVerweis(Wenn(N5="";N4;N5);Wenn(ZählenWenn(N4:N5;"K")=0;Tabelle1!$A$2:$B$40;hier der andere Zellbereich);2;0))
gruß Daniel

Bild

Betrifft: AW: Deine Angaben sind mE nicht eindeutig ...
von: ... neopa C
Geschrieben am: 19.08.2015 12:42:34
Hallo Ralf,
... um nicht zu schreiben, dass in Deiner Tabelle1 für mich nach etwas "Chaos" aussieht.
Vielleicht meintest Du folgende Formel in N6 (nach rechts und links kopierbar):
=WENN(N4&N5="";"";WENN(N4="";0;SVERWEIS(N4;Tabelle1!$A$2:$C$40;3;0)))
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Deine Angaben sind mE nicht eindeutig ...
von: Ralf
Geschrieben am: 19.08.2015 14:37:46
Hallo Werner ,
Tabelle 1 ist auch Chaos, aber nur ein Hilfsblatt. Deine Formel funktioniert fast, nur schreibt er mir jetzt nicht mehr die korrekten Werte aus Tabelle1 Spalte B wenn kein krank "K" sondern ganz normale Dienste drin stehen. Wenn ein "K" vorkommt soll Excel mit Spalte C abgleichen sonst mit Spalte B.
Gruß Ralf

Bild

Betrifft: AW: wen dem so ist ...
von: ... neopa C
Geschrieben am: 19.08.2015 17:10:15
Hallo Ralf,
... dann so:

=WENN(N4&N5="";"";WENN(N4="";0;SVERWEIS(N4;Tabelle1!$A$2:$C$40;2+(ZÄHLENWENN(N4:N5;"k")>0);0))) 
Gruß Werner
.. , - ...

Bild

Betrifft: Danke
von: Ralf
Geschrieben am: 20.08.2015 08:33:55
Vielen Dank Werner. Schon das zweite Mal das du mir geholfen hast.
Schöne Restwoche
Ralf

Bild

Betrifft: AW: SVERWEIS mit mehreren Bedingungen
von: Ralf
Geschrieben am: 20.08.2015 10:59:45
Hallo Leute,
da war ich ein wenig voreilig und habe nicht bis zum Ende getestet. Die Anzeige der Werte für "K" klappt bestens. Nur wenn in Zeile 4 ein Wert (außer "K") steht und in Zeile 5 ein anderer gibt Excel mir jetzt den Wert von Zeile 4 zurück und nicht von Zeile 5. Das soll aber nicht sein. Zur Verdeutlichung habe ich nochmal die Beispielmappe angefügt.
https://www.herber.de/bbs/user/99701.xlsx
Ralf

Bild

Betrifft: AW: dann mit WAHL() ...
von: ... neopa C
Geschrieben am: 20.08.2015 11:32:37
Hallo Ralf,
... in P6 folgende Formel:


=WENNFEHLER(SVERWEIS(WAHL(1+(P5<>"k")*(P5>0)+(P4>0);0;P4;P5);Tabelle1!$A$2:$C$40;2+(ZÄHLENWENN(P4:P5; "k")>0);0);"") 
und nach rechts und links kopieren.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: dann mit WAHL() ...
von: Ralf
Geschrieben am: 20.08.2015 11:57:28
Danke Werner, jetzt passt es genauso wie ich mir das vorgestellt habe.
Gruß Ralf

 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS mit mehreren Bedingungen"