Microsoft Excel

Herbers Excel/VBA-Archiv

SVerweis mit zwei Suchkriterien

Betrifft: SVerweis mit zwei Suchkriterien von: Nidal
Geschrieben am: 08.09.2014 08:26:30

Guten Morgen,

in der beigefügten Tabelle versuche ich mit einem einfachen SVwerweis einen Wert zu ermitteln, der durch zwei Suchkriterien verknüpft ist. Eine Lösung mit Pivot kommt aufgrund der Datenlage nicht in Frage. Wer kann mir hier weiterhelfen?

Folgende Formel führt zu einer Fehlermeldung

+SVERWEIS((UND(WERT(A26),(WERT(B26)))),$A$5:$C$18,3,FALSCH)

Vgl. Sie in der Tabelle bitte den Formelversuch in den Zellen D26 bis D33.

Vielen Dank.

https://www.herber.de/bbs/user/92514.xlsx

  

Betrifft: AW: SVerweis mit zwei Suchkriterien von: Hajo_Zi
Geschrieben am: 08.09.2014 08:32:06

man könnte vermuten.

Tabelle1

 D
25FORMELVERSUCH
26137

verwendete Formeln
Zelle Formel Bereich N/A
D26=SUMMENPRODUKT((A5:A18=A26)*(B5:B18=B26)*C5:C18)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.13 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: SVerweis mit zwei Suchkriterien von: hary
Geschrieben am: 08.09.2014 08:39:21

Moin
2 Moeglichkeiten.



Tabelle1

 DE
26137137

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
D26=SUMMENPRODUKT(($A$5:$A$18=A26)*($B$5:$B$18=B26)*$C$5:$C$18)  =SUMPRODUCT((R5C1:R18C1=RC[-3])*(R5C2:R18C2=RC[-2])*R5C3:R18C3)
E26=SUMMEWENNS($C$5:$C$18;$A$5:$A$18;A26;$B$5:$B$18;B26)  =SUMIFS(R5C3:R18C3,R5C1:R18C1,RC[-4],R5C2:R18C2,RC[-3])

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: na ja, was ist gewollt ? von: WF
Geschrieben am: 08.09.2014 09:21:47

Hi,

mit SUMMENPRODUKT wird nicht ein gefundener Wert (der erste) ausgegeben sondern bei 2 identischen Wertepaaren die Summe davon z.B. A27 und B27

Stattdessen der Klassiker (Arrayformel):
{=INDEX(C:C;VERGLEICH(A26&B26;A$1:A$20&B$1:B$20;0))}

Funktioniert auch mit Texten in Spalte C.

Salut WF


  

Betrifft: ich bin ja blöd von: WF
Geschrieben am: 08.09.2014 09:28:46

Wunschergebnis (Summe) steht ja da.


 

Beiträge aus den Excel-Beispielen zum Thema "SVerweis mit zwei Suchkriterien"