Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt mit 2 Bedingungen


Betrifft: Summenprodukt mit 2 Bedingungen von: Georg
Geschrieben am: 26.07.2018 12:49:12

Liebe Mitglieder
ich bringe einfach nicht zwei Bedingungen in meiner Tabelle unter.
Es soll in Spalte R solange aufsummiert werden
1. solange die Pers. Nr in Spalte B identisch ist
UND
2. nur die Beträge, welche in meinem Beispiel für 2018/01 anfallen.

Es sollte also in Spalte R eig. stehen für Müller 264 €
für Mustermann auch 264 €, für Beispiel Franz 132 (2x 66) etc

Ich bekomme in meiner Datei nur die erste Bedingung unter:
Die Datei dazu ist hier

https://www.herber.de/bbs/user/122918.xlsx

Vielen Dank schon im Voraus.Georg

  

Betrifft: diesen Beitrag bitte ignorieren von: Georg
Geschrieben am: 26.07.2018 12:50:13

wurde 2x versehentlich eingestellt


  

Betrifft: AW: Summenprodukt mit 2 Bedingungen von: SF
Geschrieben am: 26.07.2018 12:51:40

Hola,

die 2. Bedingung ist:

Q2:Q33="01/2018"
Gruß,
steve1da


  

Betrifft: AW: Summenprodukt mit 2 Bedingungen von: Georg
Geschrieben am: 26.07.2018 13:00:29

Danke, aber an welcher Stelle plaziere ich deinen Vorschlag? Mit wenn..oder wenn(.. mit UND verknüpfen, es kommt nicht das raus, was ich möchte??


  

Betrifft: AW: Summenprodukt mit 2 Bedingungen von: SF
Geschrieben am: 26.07.2018 13:01:13

Hola,

so wie die erste Bedingung:

=WENN(B2<>B1;SUMMENPRODUKT(($B$2:$B$33=B2)*($G$2:$G$33)*(Q2:Q33="01/2018"));"")

Gruß,
steve1da


  

Betrifft: danke, von: Georg
Geschrieben am: 26.07.2018 13:05:06

..hab mich glaube gerade etwas ... angestellt. Ge


Beiträge aus dem Excel-Forum zum Thema "Summenprodukt mit 2 Bedingungen"