Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Userform
BildScreenshot zu Userform Userform-Seite mit Beispielarbeitsmappe aufrufen

Liste mit 2 Kriterien sortieren... | Herbers Excel-Forum


Betrifft: Liste mit 2 Kriterien sortieren... von: Uwe Hladik
Geschrieben am: 19.10.2008 20:47:49

Guten Abend an Alle,

brauche mal Hilfe bei der sortierung einer liste.
In F1 soll der beste Spieler aus der Liste angezeigt werden, der die kürzeste Zeit benötigt hat, und dabei am wenigsten Fehler gemacht hat.

...wie kann man sowas machen.
Mit der Funktion Rang und KKleinste hab ich nix hin bekommen.
https://www.herber.de/bbs/user/56123.xls

Vorab schon mal Dank!!
Gruß Uwe

  

Betrifft: AW: Liste mit 2 Kriterien sortieren... von: ransi
Geschrieben am: 19.10.2008 20:58:08

HAllo Uwe

Als erstes solltest du das was Zahlen sind auch als Zahlen eintragen.
Sowas:
00.00.10
ist für Excel Text.
Also für eine Auswertung denkbar ungeeignet.
Wenn du dich entschließen köntest das so zu änder:
00:00:10 wirds einfacher.

Mit den Punkten gehts z.B. so:
Tabelle1

 ABCDEF
1NameZeitFehler Bester SpielerJupp
2Uwe00.00.10885,0088  
3Hans00.00.13877,0087  
4Karl00.00.12866,0086  
5Jupp00.00.02851,0085  
6Peter00.00.04844,0084  
7Paul00.00.04834,0083  
8Paul00.00.04824,0082  
9      

Formeln der Tabelle
ZelleFormel
F1=INDEX(A2:A8;VERGLEICH(MIN(D2:D8); D2:D8;0))
D2=ZÄHLENWENN($B$2:$B$8;"<="&B2)+C2%%


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Mit ":" gehts wahrscheinlich auch ohne Hilfsspalte.

ransi


  

Betrifft: AW: Liste mit 2 Kriterien sortieren... von: Uwe Hladik
Geschrieben am: 19.10.2008 21:14:16

Hallo Ransi,

erstmal vielen Dank!!!
Funktioniert soweit gut.
Eine Frage hab ich noch.....
Die Liste wird über eine Userform weiter gefüttert.
Wenn jetzt einer dazu kommt, zeigt er nur noch #Bezug.
Was muß man da ändern?

Gruß Uwe


  

Betrifft: AW: Liste mit 2 Kriterien sortieren... von: Ulf M
Geschrieben am: 19.10.2008 21:04:14

Hallo Uwe

Ich habe dir mal die Datei hochgeladen

Habe es mit 2 Hilfsspalten gelöst. Diese Spalten kannst du ja ausblenden.

https://www.herber.de/bbs/user/56125.xls

mfg Ulf


  

Betrifft: AW: Liste mit 2 Kriterien sortieren... von: Uwe Hladik
Geschrieben am: 19.10.2008 21:22:54

Hallo Ulf,
auch Dir vielen Dank!!!

Deinen Vorschlag funktioniert soweit auch. Leider die selbe Frage an Dich. Wie funktioniert das wenn die Liste sich erweitert. Die Daten werden über eine UF eingelesen.

Gruß Uwe


  

Betrifft: AW: Liste mit 2 Kriterien sortieren... von: Ulf M
Geschrieben am: 19.10.2008 21:29:06

Hallo Uwe

Habe die Datei erweitert für Maximal 100 Personen.


https://www.herber.de/bbs/user/56126.xls


mfg Ulf


  

Betrifft: AW: Liste mit 2 Kriterien sortieren... von: Uwe Hladik
Geschrieben am: 20.10.2008 14:45:05

Hallo Ulf,

danke nochmals für die Nacharbeit!!!!
Werde das jetzt mal versuchen umzusetzen.

Gruß Uwe


Beiträge aus den Excel-Beispielen zum Thema "Liste mit 2 Kriterien sortieren..."