Microsoft Excel

Herbers Excel/VBA-Archiv

Suche mit 3 Kriterien

Betrifft: Suche mit 3 Kriterien von: Dennis
Geschrieben am: 27.10.2020 08:03:20

Hallo zusammen,

folgendes Szenario..

An den Anlagen, tragen die Mitarbeiter in einer definierten Datei, ihre Produktionsdaten ein.
Per VBA, lasse ich mir diese Daten gebündelt immer zu Schichtende oder Produktwechsel übertragen.

In meiner Auswertung, werte ich diese Daten aus. Dazu habe ich pro Anlage 6 Übergaben/Einzelauswertungen mit bis zu 20 Materialien...

Bis hierhin, arbeite ich lediglich mit den Nettodaten.

Was ich für meine weitere Arbeit benötige sind die Bruttowerte...
Dazu habe ich mir etwas für den Auszug der Datenbank aus SAP gebastelt.

Ich Suche seit mehreren Wochen eine Möglichkeit in dieser Datenbank nach Werten zu Suchen.
Ich muss die Artikel, Positionsnummer und Materialnummer als Kriterium haben, da die Datenbank wie folgt aufgebaut ist

A= Artikel
E= Positionsnummer
K= Materialnummer
P= Ergebnis 1
Q= Ergebnis 2

  • A | E | K | | | | P | | Q
    47996 | 2 | 395121 | ROH | Zu-streus.bunt .NF | KG | 0 | 1.000 | 3
    47996 | 1 | 916463 |HALB | Eis Cake Batter | KG | 610 | 1.000 | 0

    Wenn bei Ergebnis 1 etwas steht, steht bei 2 nichts und umgekehrt.
    Anders unterscheiden kann man leider auch nicht, da die Materialnummer ggf. in mehreren Artikel auftauchen kann und da andere Ergebnisse hinterlegt sind... und Übersichtlich ist das ganze auch nicht, da dort weit über 60.000 Zeilen mit Daten gefüllt sind.

    Ich habe mir bereits folgende Formel gebaut...
    "{=WENN(ISTFEHLER(SVERWEIS($A27&$A29&L27;WAHL({1.2};'xxx[Ausschuss.xlsx]Sheet1'!$A:$A&;'xxx[Ausschuss.xlsx]Sheet1'!$E:$E&;'xxx[Ausschuss.xlsx]Sheet1'!$F:$F;'xxx[Ausschuss.xlsx]Sheet1'!$J:$J);2;0));"""";SVERWEIS($A27&$A29&L27;WAHL({1.2};'xxx[Ausschuss.xlsx]Sheet1'!$A:$A&;'xxx[Ausschuss.xlsx]Sheet1'!$E:$E&;'xxx[Ausschuss.xlsx]Sheet1'!$F:$F;'xxx[Ausschuss.xlsx]Sheet1'!$J:$J);2;0))}
    "

    Jedoch wir die Datei dadurch extrem Langsam.
    Ich habe leider nicht nur 1 Feld, wo ich nach diesen Werten Suche, sondern 8 Anlagen á 6 Einzelauswertungen.

    Es müssen nicht alle gleichzeitig gesucht werden, da ich jede Anlage separat bearbeite und die Kriterien sich automatisch ändern, je nachdem welche Anlage ich grade Auswerte.

    Hier die Beispieldatei ( https://www.herber.de/bbs/user/141117.xlsx )

    Vielleicht steigt jemand durch und kann mir ne schnelle und einfache Lösung nennen. Ich steh jedenfalls auf dem bekannten Schlauch =/

    Betrifft: AW: Suche mit 3 Kriterien
    von: SF
    Geschrieben am: 27.10.2020 08:20:20

    Hola,

    lass die Formel nicht über ganze Spalten laufen. Warum Istfehler() wenn es doch Wennfehler() gibt?
    Probier eine der dortigen Nicht-Matrix-Formeln aus:
    https://www.herber.de/excelformeln/pages/SVERWEIS_bei_mehrspaltigen_Suchkriterien_Mehrfachtreffer.html

    Gruß,
    steve1da

    Betrifft: AW: das ist keine Datenbeispieldatei sondern ...
    von: neopa C
    Geschrieben am: 27.10.2020 08:39:47

    Hallo Dennis,

    ... sondern eine Datei in der der nochmal Deine Problembeschreibung darstellst.

    Bei auszuwertenden 60.000 Datensätze noch dazu über eine "Fremd"-Datei, sollte man auch über andere Auswertungsmöglichkeiten nachdenken als Deinen Formelansatz.

    Möglicherweise käme eine Auswertung über Daten abrufen und transformieren in Frage. Aber auch eine einfachere Formellösung wäre denkbar. Aber Dein Datenstruktur mit Beispieldaten nachstellen wird wohl keiner.

    Gruß Werner
    .. , - ...

    Betrifft: AW: Suche mit 3 Kriterien
    von: Dennis
    Geschrieben am: 27.10.2020 09:00:08

    Hallo Steve und Werner,

    Danke erstmal Steve für den Link. Werde ich mir anschauen.

    Werner... Leider kann ich das nicht als komplette Formel stehen lassen, da in der Formel die Pfade hinterlegt sind dort schon Firmeninfos drin stehen, welche ich nicht nach außen Tragen darf -.-
    Es soll auch nur zum überblick dienen, wie das aufgebaut ist.

    Betrifft: AW: Daten sind nicht im Original notwendig ...
    von: neopa C
    Geschrieben am: 27.10.2020 09:05:57

    Hallo Dennis,

    ... und natürlich auch nicht komplett. Ausreichend wäre eine Handvoll anonymisierte Daten mit gleicher Datenstruktur und anstelle zwei Dateien auch nur zwei Tabellenblätter in einer Datei.

    Gruß Werner
    .. , - ...

    Betrifft: AW: Suche mit 3 Kriterien
    von: Dennis
    Geschrieben am: 27.10.2020 10:50:24

    Steve ich danke dir für den Tipp ♥

    "=WENNFEHLER(WENN(B12="";"";INDEX('Kopie von Stücklisten HAA.xlsx'!Ausschuss[Ausschuss Glatt (%)];VERGLEICH(1;MMULT(('Kopie von Stücklisten HAA.xlsx'!Ausschuss[Material]=$A12)*('Kopie von Stücklisten HAA.xlsx'!Ausschuss[Positionsnr2]=$A13)*('Kopie von Stücklisten HAA.xlsx'!Ausschuss[Komponente]=B12);1);0)));"")"

    hat mich zum Ziel gebracht und dabei bleibt die Datei noch geschmeidig ♥

    Kuss auf die Nuss

    Beiträge aus dem Excel-Forum zum Thema "Suche mit 3 Kriterien"