Herbers Excel-Forum - das Archiv

Matrix mit mehreren Kriterien



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Matrix mit mehreren Kriterien
von: Marc


Geschrieben am: 20.05.2002 - 16:13:38

Hallo,

ich habe zwei Tabellen, in der ersten stehen Name, Vorname und besuchte Kurse. In der zweiten Tabelle stehen Name, Vorname und Personalnummer. Nun möchte ich in der ersten Liste eine Spalte Personalnummer hinzufügen, die sich die Werte aus der zweiten Liste, abhängig von Name UND Vorname, holt.
Vielen Dank im Vorraus....


nach oben   nach unten

Re: Matrix mit mehreren Kriterien
von: Monika Weber


Geschrieben am: 20.05.2002 - 16:30:39

Hallo Marc

Wenn du mit einer Hilfsspalte leben kannst, dann füge auf dem 2. Tabellenblatt zwischen dem Vornamen und der Personalnummer eine Spalte ein.
Gib dort eine Formel ein, welche den Namen und Vornamen verkettet:
=A2&B2
Mit "Autoausfüllen", kannst du die Formel runterziehen.
(Wenn dich die Spalte stört, kannst du sie ausblenden)

Auf dem ersten Tabellenblatt könnte der SVerweis nun so aussehen:
=SVERWEIS(A2&B2;Tabelle2!C2:D100;2;0)

Es liebs Grüessli
Monika

Re: Matrix mit mehreren Kriterien
von: Rainer3


Geschrieben am: 20.05.2002 - 17:20:48

Hallo Marc,

es geht auch ohne Hilfsspalte mit einer Arrayformel.

Bei Deiner genannten Tabellenstruktur müßtest Du in Tabelle1 Zelle D2 folgende Formel schreiben und runterkopieren.

{=INDEX(Tabelle2!C2:C100;VERGLEICH(Tabelle1!A2:A100&Tabelle1!B2:B100;Tabelle2!A2:A100&Tabelle2!B2:B100;0))}

geschweifte Klammern nicht mit eingeben, sie werden durch STRG+SHIFT+ENTER automatisch erzeugt.

Die Formel ist auf 100 Zeilen ausgerichtet, wenn Du mehr hast mußt Du alle "100" in der Formel durch die entsprechende Zeilenzahl ersetzen.

Gruß
Rainer

nach oben   nach unten

Re: Matrix mit mehreren Kriterien
von: Marc
Geschrieben am: 20.05.2002 - 22:21:41

Klappt wunderbar,

Vielen Dank und Schönen Gruß.....!


 nach oben

Excel-Beispiele zum Thema "Matrix mit mehreren Kriterien"
Entfernungsmatrix listen Ausgabe einer benutzerdefinierten Funktion in Matrixformel
Werte aus Zellbereich in eine Matrix übernehmen und auslesen Portokosten aus einer Gewichts-/Gebietsmatrix errechnen
Matrix in UserForm-ListBox einlesen SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele
Anzahl nach 2 Kriterien ermitteln mit DB-Funktion und MatrixFormel Werte aus Matrix in zweitem Blatt auflisten
Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen Daten in Matrix indizieren