Live-Forum - Die aktuellen Beiträge
Datum
Titel
15.07.2024 16:00:57
15.07.2024 15:41:38
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Standzeitenberechnung mit mehreren Kriterien

Standzeitenberechnung mit mehreren Kriterien
12.02.2019 16:25:01
Thomas
Mahlzeit zusammen,
ich komme leider nicht weiter und benötige dringend Hilfe, folgende Thematik
Ich muss eine Auswertung über die Standzeiten von Trailern erstellen.
Dabei ist zu beachten, wenn der Trailer nach 16:00 Uhr gestellt wurde,
zählt die Zeit erst ab dem Folgetag um 08:00 Uhr. Ab da aber komplett bis zur abgeschlossenen Entladung. Wochenenden (Samstag + Sonntag) sind ausgeschlossen.
A2 B2 C2 D2 E2
01.10.2018 09:28 08.10.2018 08:30 Standzeit
Jegliche Berechnungen haben leider nicht funktioniert und ich bekomme es nur mit zwei Teilberechnungen hin, die ich aber nicht zusammen fügen kann.
Ich hoffe es kann mir jemand helfen, Vielen Dank im Voraus!
https://www.herber.de/bbs/user/127604.xlsx

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Standzeitenberechnung mit mehreren Kriterien
12.02.2019 16:45:14
Sven
Hallo,
anbei mein Lösungsansatz. Es wird die Zeit in Stunden errechnet (sofern ich das fachlich richtig verstanden habe). Durch die 16-Uhr-Regel passt es nicht immer, da manchmal auch nach 16 Uhr noch eine Entladung abgeschlossen wurde und daher die Zeit negativ ist (Zeile 19 bspw.).
https://www.herber.de/bbs/user/127608.xlsx
Grüße
Sven
AW: Standzeitenberechnung mit mehreren Kriterien
12.02.2019 17:49:39
Thomas
Guten Abend Sven,
das sieht schon sehr gut aus, allerdings hast Du genau wie ich nicht das Problem gelöst,
wenn der Trailer nach 00:00 Uhr abgestellt wird. Auch dann darf die Zeit erst ab 08:00 Uhr am selben Tag zählen. Beispiel Spalte 147:
  • Montag, 26. November 2018 3:50 Dienstag, 27. November 2018 9:25 26.11.2018 03:50:00 26.11.2018 03:50 27.11.2018 09:25 29,58333333

  • Anzeige
    AW: Standzeitenberechnung mit mehreren Kriterien
    12.02.2019 19:52:34
    Thomas
    Ich habe leider noch eine Frage,
    wie bekomme ich die Wochenenden aus der Rechnung heraus, Nettoarbeitstage funktioniert in Kombi mit Uhrzeit so ja leider nicht.
    Gibt es hierzu noch Ideen?
    https://www.herber.de/bbs/user/127604.xlsx
    AW: Standzeitenberechnung mit mehreren Kriterien
    12.02.2019 19:53:53
    onur
    Wenn du nicht mal meine Frage beantwortest?
    AW: Standzeitenberechnung mit mehreren Kriterien
    12.02.2019 16:57:12
    Werni
    Hallo Thomas
    So ..
     EF
    1Stunden MinutenTage Stunden Minuten
    2141:2405 Tage 21:24

    ZelleFormatWert
    E2[hh]:mm5.89166666667006
    F2TT "Tage" hh:mm04.01.1900 21:24:00

    ZelleFormel
    E2=SUMME(C2:D2)-SUMME(A2:B2)
    F2=SUMME(C2:D2)-SUMME(A2:B2)

    Gruss Werni
    Anzeige
    AW: Standzeitenberechnung mit mehreren Kriterien
    12.02.2019 17:18:47
    Thomas
    Servus Werni,
    Vielen Dank für Deinen Ansatz, dass
    das berücksichtigt aber nicht die Kriterien, dass wenn die Gestellung erst nach
    16:00 Uhr stattfindet, erst ab 08:00 Uhr am Folgetag berechnet werden darf.
    Und genau da tritt das Problem mit dem 24 Uhr auf etc.
    AW: Standzeitenberechnung mit mehreren Kriterien
    12.02.2019 17:45:17
    onur
    Und wenn Montag 8:00 abgestellt und Mittwoch 16:00 entladen wurde- sind das 24 Stunden (3x8,00) oder 56 Stunden (16+24+16) ?
    Soll heissen: Sind die Stunden zw. 16:00 und 8:00 prinzipiell aus der Berechnung ausgeschlossen?
    Das lässt sich aus deiner Problembeschreibung nicht eindeutig erschliessen.

    319 Forumthreads zu ähnlichen Themen

    Anzeige
    Anzeige
    Anzeige
    Anzeige

    Beliebteste Forumthreads (12 Monate)

    Anzeige

    Beliebteste Forumthreads (12 Monate)

    Anzeige
    Anzeige
    Anzeige