Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

INDIREKT 2x in einer Zelle?

INDIREKT 2x in einer Zelle?
04.10.2016 08:03:12
erichm
Hallo,
mit INDIREKT möchte ich durch Vergleich von Bereichen doppelte, mehrfache Zahlen finden. Das klappt mit 1 x INDIREKT - aber wie geht es mit 2mal in einer Formel?
Im nachstehenden Beispiel müsste jeweils der Buchstabe in Spalte E in die Formel ab Spalte F per INDIREKT eingebaut werden:
indirekt2x

 ABCDEFGHIJKLMNO
1           Zeilen
2ABC  65432 6543
3289654222        gefundene Zahlen
4431222600 I10    222 -  
5654350435 H010    -654--
6289654589 G1020  654-289 / 654 -
7111735289 F10010 289 - -289

Formeln der Tabelle
ZelleFormel
G2=+F2-1
H2=+G2-1
I2=+H2-1
J2=+I2-1
F4{=SUMME(ZÄHLENWENN($A4:$C4;INDIREKT("A"&I$2&":C"&I$2)))}
G4{=SUMME(ZÄHLENWENN($A4:$C4;INDIREKT("A"&J$2&":C"&J$2)))}
F5{=SUMME(ZÄHLENWENN($A5:$C5;INDIREKT("A"&H$2&":C"&H$2)))}
G5{=SUMME(ZÄHLENWENN($A5:$C5;INDIREKT("A"&I$2&":C"&I$2)))}
H5{=SUMME(ZÄHLENWENN($A5:$C5;INDIREKT("A"&J$2&":C"&J$2)))}
F6{=SUMME(ZÄHLENWENN($A6:$C6;INDIREKT("A"&G$2&":C"&G$2)))}
G6{=SUMME(ZÄHLENWENN($A6:$C6;INDIREKT("A"&H$2&":C"&H$2)))}
H6{=SUMME(ZÄHLENWENN($A6:$C6;INDIREKT("A"&I$2&":C"&I$2)))}
I6{=SUMME(ZÄHLENWENN($A6:$C6;INDIREKT("A"&J$2&":C"&J$2)))}
F7{=SUMME(ZÄHLENWENN($A7:$C7;INDIREKT("A"&F$2&":C"&F$2)))}
G7{=SUMME(ZÄHLENWENN($A7:$C7;INDIREKT("A"&G$2&":C"&G$2)))}
H7{=SUMME(ZÄHLENWENN($A7:$C7;INDIREKT("A"&H$2&":C"&H$2)))}
I7{=SUMME(ZÄHLENWENN($A7:$C7;INDIREKT("A"&I$2&":C"&I$2)))}
J7{=SUMME(ZÄHLENWENN($A7:$C7;INDIREKT("A"&J$2&":C"&J$2)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Ich komme nicht auf die Lösung?
Danke.
mfg

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: ohne INDIREKT(), ohne {}, ohne Hilfszellen ...
04.10.2016 09:09:50
...
Hallo Erich,
... und dazu kurz und bündig auch ohne AGGREGAT() ;-) aber als Matrixfunktion(alität)sformel in F4:

=WENN(L4="";"";ANZAHL(INDEX(FINDEN($A4:$C4;L4);)))

und Formel nach rechts und unten kopieren.
Gruß Werner
.. , - ...
AW: ohne INDIREKT(), ohne {}, ohne Hilfszellen ...
04.10.2016 17:14:26
erichm
oh sorry - da war meine Beschreibung nicht ausreichend bzw. eindeutig!
In den Zellen L4 bis O7 habe ich informativ nur die Zahlen aufgeführt, die in den Spalten F bis J gefunden wurden (deswegen auch in der Zelle N6 zwei Zahlen).
Die Zellen für die Formelgrundlage sind deswegen nur die Spalten A bis C sowie ggfls. die Hilfsspalte F.
Hoffe, das ist jetzt klarer.
Nochmals danke für eine Hilfe!
mfg
Anzeige
AW: gut. dann beginnen wir eben neu ...
04.10.2016 17:47:52
...
Hallo Erich,
... was genau hast Du wirklich an Daten in der Tabelle und was willst Du wie ausgewertet haben. Für Dein Ergebniswerte lass bitte evtl. Hilfszellen und Formeln weg. Vielleicht wird es mir dann klarer.
Gruß Werner
.. , - ...
AW: gut. dann beginnen wir eben neu ...
04.10.2016 18:22:19
erichm
ok ohne Formeln:
indirekt2x (2)

 ABCDEFGHIJ
1DATEN  Ergebnisse    
2ABC  65432
3289654222       
4431222600  10   
5654350435  010  
6289654589  1020 
7111735289  10010


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Aufgabe:
- vergleiche die Zahlen pro Zeile mit den anderen Zeilen
- derzeit muss von unten nach oben geprüft werden
(das könnte man aber auch umsortieren für einen Vergleich von oben nach unten)
- zähle wieviele Zahlen pro Zeile mit der anderen Zeile übereinstimmen, auch wenn in unterschiedlichen Spalten
- die Zählergebnisse ab Spalte F eintragen:
Vergleich der Zeile 7 mit 6 in Spalte F, Zeile 7
Vergleich der Zeile 7 mit 5 in Spalte G, Zeile 7
Vergleich der Zeile 7 mit 4 in Spalte H, Zeile 7 usw…..
Vergleich der Zeile 6 mit 5 in Spalte F, Zeile 6
Vergleich der Zeile 6 mit 4 in Spalte G, Zeile 6
Vergleich der Zeile 6 mit 3 in Spalte H, Zeile 6 usw…..
Ich habe die Zahlen und die Ergebnisse die zusammengehören soweit möglich farblich markiert.
In Spalte H6 steht eine 2 weil beim Vergleich der Zeile 6 mit der Zeile 3 die beiden Zahlen 289 und 654 übereinstimmend gefunden wurden.
Danke nochmal.
mfg
Anzeige
AW: dann INDEX() u. ZÄHLENWENN() ohne {} ...
04.10.2016 18:45:25
...
Hallo Erich,
... und auch wieder in einer Matrixfunktion(alität)sformel
Nachfolgende Formel nach rechts und unten ziehend kopieren:
 ABCDEFGHIJ
1DATEN  Ergebnisse
2ABC  65432
3289654222       
4431222600  1    
5654350435  01   
6289654589  102  
7111735289  1001 
8          

Formeln der Tabelle
ZelleFormel
F3=WENN(ZEILE(A3)-SPALTE(A3)<3;"";SUMME(INDEX(ZÄHLENWENN($A3:$C3;INDEX($A$1:$A3;ZEILE()-SPALTE(A3)):INDEX($C$1:$C3;ZEILE()-SPALTE(A3))); )))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...
Anzeige
AW: dann INDEX() u. ZÄHLENWENN() ohne {} ...
04.10.2016 19:12:21
erichm
Geht ja fix - jetzt perfekt gelöst!!
DANKE!
mfg
AW: hätten wir auch eher haben können ;-) owT
05.10.2016 08:25:40
...
Gruß Werner
.. , - ...

377 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige