Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

spezieller sverweis mit 3 Suchkriterien.

spezieller sverweis mit 3 Suchkriterien.
11.05.2009 09:50:39
Andi
Hallo zusammen
ich suche eine speziellen Sverweis mit 3 Suchkriterien. Er soll zwei Spalten nach den exakten werten durchsuchen. und die 3te nach dem exakten, falls vorhanden, falls nicht vorhanden, dann nach dem nächst kleineren.
Genaueres habe ich hier beschrieben: https://www.herber.de/bbs/user/61728.xls
Vielen Dank für eure Hilfe!
Mit freundlichen Grüssen
Andi

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: spezieller sverweis mit 3 Suchkriterien.
11.05.2009 10:14:25
Tino
Hallo,
versuche es mal hiermit, die Datumsspalte muss aber aufsteigend Sortiert sein,
wie in Deinem Beispiel.
 ABCD
1NameDatumMengeRechnungsnummer
2Name101.01.20092212345
3Name201.06.20093323456
4Name401.11.20094534567
5Name101.04.20102245678
6Name101.09.20102256789
7Name301.02.20114411223
8Name501.07.20116622334
9Name201.12.20113333445
10Name401.05.20124555667
11Name101.10.20122288989
12Name101.03.20132233449
13Name301.08.20134445632
14    
15    
16    
17Gesucht:   
18NameDatum MengeRechungsnummer
19Name101.01.20112256789

Formeln der Tabelle
ZelleFormel
D19=SUMMENPRODUKT(($A$2:$A$13=A19)*($B$2:$B$13=SVERWEIS(B19;$B$2:$B$13;1;WAHR))*($C$2:$C$13=C19)*($D$2:$D$13))

Gruß Tino
Anzeige
..irgendwo einen Fehler...
11.05.2009 10:21:56
Andi
Hallo Tino
Vielen Dank für die Antwort..
Funktioniert leider noch nicht ganz..wenn ich in meiner Datei in B19 01.12.2009 eingebe, und Name und Menge so belasse, bekomme ich den Lösungswert 0. Es sollte dann aber 12345 anzeigen..
MFG
Andi
fehlerhaft - mit VERWEIS funktionierts
11.05.2009 11:08:34
WF
Hi,
steht in B7 z.B. der 25.10.2010 wird nichts ausgegeben - sowie Beispielsfehler von Andi.
Das sollte funktionieren (Spalte B muß aber weiterhin aufsteigend sein):
=VERWEIS(2;1/(($A$2:$A$13=A19)*($C$2:$C$13=C19)*(B2:B13<=B19)<>0);D2:D13)
Salut WF
AW: spezieller sverweis mit 3 Suchkriterien.
11.05.2009 11:27:19
Tino
Hallo,
nicht so schön wie WF seine, geht aber auch. ;-)
 ABCD
17Gesucht:   
18NameDatum MengeRechungsnummer
19Name101.12.20092212345

Formeln der Tabelle
ZelleFormel
D19{=SUMMENPRODUKT(($A$2:$A$13=A19)*($B$2:$B$13=MAX(WENN(($A$2:$A$13=A19)*($C$2:$C$13=C19)*($B$2:$B$13<=B19); $B$2:$B$13)))*($C$2:$C$13=C19)*($D$2:$D$13))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Gruß Tino
Anzeige
das gibt aber Murks, wenn ...
11.05.2009 14:48:11
WF
... es 2 identische, relevante Datümer gibt - dann werden die Artikelnummern addiert.
Salut WF
stimmt auch wieder. oT.
11.05.2009 14:59:27
Tino

317 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige