Microsoft Excel

Herbers Excel/VBA-Archiv

Verweis mit 2 Suchkriterien

Betrifft: Verweis mit 2 Suchkriterien von: Tanja
Geschrieben am: 12.08.2014 11:43:45

Hallo liebes Forum,

nachdem ich hier schon einige Probleme durch die bisherige Beiträge lösen konnte (toll, dass es dieses Forum gibt!), komme ich nun alleine nicht weiter und bitte euch um eure Hilfe.

In Tabellenblatt 1 habe ich Datum (B), Ausfallzeiten (C) und Schicht (D). In einer weiteren Spalte summiere ich die Ausfallzeiten pro Tag und Schicht (E). Da es zu mehr Ausfällen in einer Schicht kommen kann, ist nicht in jeder Zelle der Spalte Ausfallzeiten eine Zahl, sondern ich summiere die Zeiten in der letzten Zelle auf.

In Tabellenblatt 2 habe ich ebenfalls Datum (A), Schicht (B) und Stückzahl (C). Nun möchte ich passend zu Datum und Schicht die ermittelte Gesamtausfallzeit aus Tabelle 1 ermitteln und in Tabelle 2 anzeigen lassen.

Bisher habe ich 2 Varianten aufgebaut, die mir jedoch beide #NV zurückgeben. (s.Tabelle2 Spalte D&E)

{=VERWEIS(2;1/(Tabelle1!B:B&"*"&Tabelle1!D:D=A2&"*"&B2);Tabelle1!E:E)}

=INDEX(Tabelle1!A:E;VERGLEICH(Tabelle2!A2&Tabelle2!B2;Tabelle1!B:B&Tabelle1!D:D;0);5)

Ebenfalls sollte die Formel berücksichtigen, dass es nicht an jedem Tag zu Ausfällen kommt. Wenn nichts gefunden wird, sollte eine 0 angezeit werden.

Die Datei findet ihr hier:
https://www.herber.de/bbs/user/92039.xlsx

Leider komme ich durch die Suche im Internet nicht mehr weiter, daher hoffe ich auf eure Ideen! Wenn möglich mit einer Excel-Funktion. Anderweitig wäre auch ein Makro ok, da ich die Formel später sowieso in ein Makro einbinde (wobei ich dies, wegen meinen schlechten VBA-Kenntnissen, über Makro aufzeichnen realisiere)

Lieben Dank schonmal,

Tanja

  

Betrifft: so ist alles = 0 ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 11:53:59

Hallo Tanja,

weil Du in Tabelle1 nur Jahr 2013 protokolliert hast.

Die Formel in D2 besser so: =WENNFEHLER(VERWEIS(9;1/(Tabelle1!B$1:B$99=A2)/(Tabelle1!D$1:D$99=B2);Tabelle1!E$1:E$99);0)



Gruß Werner
.. , - ...


  

Betrifft: AW: so ist alles = 0 ... von: Tanja
Geschrieben am: 12.08.2014 12:29:10

War ein Versehen in der Beispieldatei. In der Beispieldatei funktioniert es jetzt auch, nur leider nicht in der richtigen Datei. Muss ich mich wohl nochmals auf Fehlersuche mache.

Danke schonmal!


  

Betrifft: AW: Verweis mit 2 Suchkriterien von: Tanja
Geschrieben am: 12.08.2014 12:38:14

War ein Versehen in der Beispieldatei. In der Beispieldatei funktioniert es jetzt auch, nur leider nicht in der richtigen Datei. Muss ich mich wohl nochmals auf Fehlersuche mache.

Danke schonmal!


  

Betrifft: AW: Verweis mit 2 Suchkriterien von: Daniel
Geschrieben am: 12.08.2014 12:40:14

Hi
sieht für mich nach einem Fall für SummeWenns aus:

=SUMMEWENNS(Tabelle1!C:C;Tabelle1!B:B;A2*1;Tabelle1!D:D;B2)

damit wird dann die Hilfsspalte E unnötig.
Das Problem mit den Unterschiedlichen Jahren (2013 und 2014) in Tabelle 1 und 2 wurde ja schon angesprochen.
Gruß Daniel


  

Betrifft: AW: Verweis mit 2 Suchkriterien von: Tanja
Geschrieben am: 12.08.2014 13:58:59

Danke, die Formel hatte ich in Tabelle1 ja auch schon verwendet, bin aber gerade nicht darauf gekommen, dass die genauso funktioniert.

Ich habe trotzdem die Verweisfunktion genutzt und jetzt geht sie auch in meiner richtigen Datei, wo natürlich eine benötigte Spalte anders formatiert war als ich dachte... somit konnte keine Formel funktionieren.

Danke für die Hilfe!


 

Beiträge aus den Excel-Beispielen zum Thema "Verweis mit 2 Suchkriterien"