Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Sverweis 2 Kriterien (worte) finden

Sverweis 2 Kriterien (worte) finden
Susi
Hallo Ihr lieben Genies,
ich bekomme es nicht hin ..
=WENN(INDEX(A:A;VERGLEICH("- AA";Tabelle1!G:G;0))=A2;INDEX(Tabelle1!L:L;VERGLEICH(A2;A:A;0)))
gibt #NV wieder. versuche dieses ISTNV einzubauen ist mir nicht gelungen.
2 Tabellen
1T
Spalte A ......Spalte D
Gr 1 -......... #NV hier soll Susi stehen
Gr 2 -...........#NV hier soll Paul stehen
2T
Spalte A...........Spalte L
Gr 1 - AA..........Susi
Gr 2 - AA BB......Martin
Gr 2 - AA ......... Paul
Gr 3 - AA BB ......Karin
Gr 3 - AA ......... Joachim
könnte man eigentlich, wenn nötig noch ein 3. Kriterien (suche in 2T SA) einbauen, dann brauche ich nicht noch mal fragen.
vorab schon mal vielen herzlichen Dank!
Gruß Susi
Korrektur: Sverweis 2 Kriterien (worte) finden
22.02.2011 12:30:09
Susi
also noch mal mit korrektur, aber geht auch nicht ...
ich bekomme es nicht hin ..
=WENN(INDEX(A:A;VERGLEICH("- AA.";Tabelle2!G:G;0))=A2;INDEX(Tabelle2!L:L;VERGLEICH(A2;A:A;0)))
gibt #NV wieder. versuche dieses ISTNV einzubauen ist mir nicht gelungen.
2 Tabellen
1T
Spalte A ......Spalte D
Gr 1 -......... #NV hier soll Susi stehen
Gr 2 -...........#NV hier soll Paul stehen
2T
Spalte G...........Spalte L
Gr 1 - AA..........Susi
Gr 2 - AA BB......Martin
Gr 2 - AA ......... Paul
Gr 3 - AA BB ......Karin
Gr 3 - AA ......... Joachim
könnte man eigentlich, wenn nötig noch ein 3. Kriterien (suche in 2T SA) einbauen, dann brauche ich nicht noch mal fragen.
vorab schon mal vielen herzlichen Dank!
Gruß Susi
Anzeige
AW: Korrektur: Sverweis 2 Kriterien (worte) finden
22.02.2011 13:14:16
Jörn
Hallo Susi,
evtl wirds mit Bsp-Datei sprechender ...
Gruß
Jörn
AW: Korrektur: Sverweis 2 Kriterien (worte) finden
22.02.2011 13:54:08
Jörn
Hallo,
meinst Du vielleicht so:
=SVERWEIS(VERKETTEN(A1&" AA");Tabelle1!$G$1:$L$5;6;0)
Gruß
Jörn
AW: Korrektur: Sverweis 2 Kriterien (worte) finden
22.02.2011 14:10:23
Susi
nein ich will nichts verketten.
In Tab2 Sp D sollen die Namen eingetragen werden, wenn
1 Kriterium Tab1 SpA soll in Tb2 SpG gefunden werden
und
2 Kriterium soll in Tab2 Spalte G das Wort "AA" gefunden werden, aber eben nicht "AA BB";
es soll also der Name aus Tab2 SalteL in Tab1 Spalte D erscheinen.
Ich hoffe ich habe mich verständlich ausgedrückt
klingt aber irgendwie kompliziert ...
Anzeige
Verketten
22.02.2011 14:19:06
Rudi
Hallo,
es wird ja auch nur der Suchbegriff verkettet, so dass du mit Sverweis arbeiten kannst.
Alternativ =SVERWEIS(A2&" AA";Tabelle1!G:L;6;)
Gruß
Rudi
AW: Korrektur: Sverweis 2 Kriterien (worte) finden
22.02.2011 13:58:28
robert
Gr 1 - =SVERWEIS(A1&" AA";Tabelle1!G1:L5;6;0)
Gr 2 - =SVERWEIS(A2&" AA";Tabelle1!G2:L6;6;0)
Hi,
formeln in tabelle2, D1 und D2
meinst du so?
gruß
robert
AW: Korrektur: Sverweis 2 Kriterien (worte) finden
22.02.2011 14:29:45
Susi
zB, diese beiden sverweise zusammen in einen sverweis kombinieren
Ergebnis erscheinen Tb2 Spalte D =SVERWEIS(A1;Tabelle1!G:L;6;FALSCH)
Ergebnis erscheinen Tb2 Spalte D =SVERWEIS(Tabelle1!G:G="AA";Tabelle1!G:L;6;FALSCH) ; aber dieses Tabelle1!G:G geht nicht, oder!
geben aber beide #NV wieder.
Anzeige
Roberts oder meine Formel getestet? owT
22.02.2011 14:40:04
Rudi
AW: Roberts oder meine Formel getestet? owT
22.02.2011 15:06:11
Susi
Hallo Rudi, hallo Robert,
=SVERWEIS(A2&"- Vors.*";Tabelle2!G:L;6;FALSCH)
so geht es, eigentlich ganz einfach, aber erst nachdem mein Brett vom Kopf weg ist, hi,hi!
die Tücke mit einer Test-Datei
die eigentliche Datei ist eine sehr große Adressen-Datenbank mit Vorsitzende und stellv. Vorsitzende. und Mitgliedern,
das Dumme ist nur, dass in dieser Spalte G
zB soetwas steht: Gr 1 - Vors., BY ....
oder Gr 1 - stell. Vors., BY ...
hinter ... können noch mehr Buchstabenkürzel stehen.
will aber nur die Vors. nicht die stellv. Vors. der Gruppen
Die Inhalte der Spalte sollen natürlich ;-) auf keinen Fall geändert werden.
Danke Euch beiden noch mal ganz herzlich für Eure Mühe.
Anzeige

305 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige