Sverweis über 2xExcel

Bild

Betrifft: Sverweis über 2xExcel
von: HokoPLM
Geschrieben am: 24.08.2015 09:08:44

Hallo, der bisherige Lösungsansatz führt leider nicht zu dem gewünschten Erfolg.Vielleicht hat jemand von Euch einen Lösungsansatz.
Hier ist eine Datenbank:
(Speicherort und Name ist konstant)
https://www.herber.de/bbs/user/99791.xlsx
Entweder gibt es dort zu Spalte A oder G eine Nummer, es kann auch vorkommen
das A und G eine passende Nummer gemeinsam haben.

in der Arbeitsexcel:

https://www.herber.de/bbs/user/99793.xlsx
muss zuerst abgeglichen werden ob zu Spalte N (Dokument) in der Datenbank eine Nummer vorhanden ist, dann eintragen in Spalte H.
Das gleiche jetzt mit Spalte G, wenn dort eine Nummer in der Datenbank zugeordnet ist,
dann muss die in Spalte H.
Wenn dort allerdings keine Nummer in der Datenbank zugeordnet ist, dann soll auch nichts in der Spalte H überschrieben werden...
Wie geht das?
Gruß, P aus M

Bild

Betrifft: AW: was ist der "bisherige Lösungsansatz"? ...
von: ... neopa C
Geschrieben am: 24.08.2015 10:45:05
Hallo P aus M,
... das geht aus Deinen Angaben nicht hervor. Auch ist nicht angegeben, was in Spalte H Datei übernommen werden soll. Schreib doch mal für Dein Beispieldateien auf, was als Ergebnis in H9:H19 ermittelt werden soll.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: was ist der "bisherige Lösungsansatz"?
von: HokoPLM
Geschrieben am: 24.08.2015 12:05:22
Hallo Werner,
Der Bisherige Lösungsansatz war eine Sverweisformel, die leider beim zweiten abgleich alles überschreibt.
hier ist die Arbeitsexcel wie sie nach den beiden SVerweisen aussehen sollte.
https://www.herber.de/bbs/user/99797.xlsx
Ja du hast recht, das hatte ich oben nicht genau erklärt,
ich hoffe dass die Excel jetzt selbsterklärend ist?!
Grüße, P aus M

Bild

Betrifft: AW: dann brauchst Du noch INDEX(...VERGLEICH())
von: ... neopa C
Geschrieben am: 24.08.2015 12:49:33
Hallo P aus M,
... sowie WENNFEHLER().
In H8 folgende Formel und diese nach unten kopieren:
=WENNFEHLER(WENNFEHLER(SVERWEIS(G8;[99791.xlsx]Stüli!$A:$B;2;);INDEX([99791.xlsx]Stüli!$F:$F;VERGLEICH(N8;[99791.xlsx]Stüli!$G:$G;)));"")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: dann brauchst Du noch INDEX(...VERGLEICH())
von: HokoPLM
Geschrieben am: 24.08.2015 13:50:14
Hallo Werner,
Ich setze die Formel ein und schreibe auch in die Formel den Pfad zur Datenbank.
Ob mit oder ohne Pfad werden die Nummern nicht eingetragen. Lediglich 3 Nummern überträgt er.
Wenn du das bei dir erfolgreich getestet hattest, kannst du hier die Excel mal hochladen?
Danke,
P aus M

Bild

Betrifft: AW: nachgefragt ...
von: ... neopa C
Geschrieben am: 24.08.2015 13:52:39
Hallo P aus M,
... hast Du auch die jeweilig von Dir hier im Forum eingestellte Dateien genutzt?
Ich gehe jetzt gleich erst einmal offline, schaue aber später noch einmal nach.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nachgefragt ...
von: HokoPLM
Geschrieben am: 24.08.2015 14:09:16
Ja Werner,
Habe an den Dateien nichts geändert.
Grüße!

Bild

Betrifft: AW: nun, dann sieh einmal ...
von: ... neopa C
Geschrieben am: 24.08.2015 16:09:24
Hallo P aus M,
... Formel einfach nach unten kopieren:
[99797.xlsx]Stüli

 GHIJKLMN
81100130021001BauteilBauteilDokument
9 30021006BauteilBauteilB-1-T100-200B1
10  BauteilBauteilB-1-T100-200B2
11  BauteilBauteilB-1-T100-200B3
121100530021003BauteilBauteilB-1-T100-200B4
13  BauteilBauteilB-1-T100-200B5
141101230021004BauteilBauteilB-1-T100-200B6
15 30021009BauteilBauteilB-1-T100-200B7
16 30021010BauteilBauteilB-1-T100-200B8
17 30021011BauteilBauteilB-1-T100-200B9
18 30021013BauteilBauteilB-1-T100-200B10
19 30021015BauteilBauteilB-1-T100-200B11

Formeln der Tabelle
ZelleFormel
H8=WENNFEHLER(WENNFEHLER(SVERWEIS(G8;[99791.xlsx]Stüli!$A:$B;2;); INDEX([99791.xlsx]Stüli!$F:$F;VERGLEICH(N8;[99791.xlsx]Stüli!$G:$G;))); "")


[99791.xlsx]Stüli

 ABCDEFG
1StamnmNummer   NummerZeichnung
21100130021001 BauteilBauteil  
31100530021003 BauteilBauteil  
41101230021004 BauteilBauteil  
51101430021006 BauteilBauteil  
611017  BauteilBauteil30021006B-1-T100-200B1
711019  BauteilBauteil30021007B-1-T100-200B6
811021  BauteilBauteil30021009B-1-T100-200B7
911025  BauteilBauteil30021010B-1-T100-200B8
1011027  BauteilBauteil30021011B-1-T100-200B9
1111030  BauteilBauteil30021013B-1-T100-200B10
1211037  BauteilBauteil30021015B-1-T100-200B11


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nun, dann sieh einmal ...
von: HokoPLM
Geschrieben am: 25.08.2015 10:37:20
Vielen Dank Werner,du hattest recht!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Sverweis über 2xExcel"