Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Verweis mit 2 Bedingungen
18.03.2017 08:34:26
kathy
Liebes Forum,
ich suche eine Formel für folgende Lösung:
Wenn Gastnummer und Rechnungsnummer übereinstimmen, dann zeige Rechnungsbetrag an, wenn Gastnummer nicht vorhanden ist, dann gebe den Rechnungsbetrag aus einem anderen Tabellenblatt an (dann wurde die Rechnung schon bezahlt).
Folgendes habe ich probiert, ich bekomme es aber nicht mit 2 Bedingungen hin:
=WENN([@[Gast-Nummer]]="";"";WENN(ISTFEHLER(SVERWEIS([@[Gast-Nummer]];Tabelle7;13;0)); [@[Rechnungs-Betrag]];SVERWEIS([@[Gast-Nummer]];Tabelle7;13;0)))
Bin für jede Hilfe dankbar.
Gruß kathy

13
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Verweis mit 2 Bedingungen
18.03.2017 08:36:14
Hajo_Zi
Hallo Kathy,
für den ersten Teil Summenprodukt(), zweiter Teil Sverweis().
Es wurde ja keine Datei verlinkt, da Lösung selber erstellt werden soll.

AW: Verweis mit 2 Bedingungen
18.03.2017 09:11:58
kathy
Hallo Hajo,
habe mal ein Beispiel hochgeladen. Wäre super, wenn Du mir nochmal helfen könntest.
https://www.herber.de/bbs/user/112263.xlsx
Vielen Dank.
Gruß kathy
AW: Verweis mit 2 Bedingungen
18.03.2017 09:21:06
Hajo_Zi
Hallo Kathy,
man muss die Aufgabe nicht beschreiben, es wissen ja alle was Du willst.
Ich habe keine Ahnung.

Gastliste
 B
7 
84905,25

verwendete Formeln
Zelle Formel Bereich N/A
B8=WENN(SUMMENPRODUKT((C3:C6="71200384")*(B3:B6=29011047)*(F3:F6))<>0;SUMMENPRODUKT((C3:C6="71200384")*(B3:B6=29011047)*(F3:F6));WENNFEHLER(SVERWEIS("71200384";Rechnungsübersicht!B3:E5;3;0);""))  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.04 einschl. 64 Bit


Gruß Hajo
Anzeige
Fehler
18.03.2017 09:24:46
Hajo_Zi
Hallo Kathy,
=WENN(SUMMENPRODUKT((C3:C6="71200384")*(B3:B6=29011047)*(F3:F6))0;SUMMENPRODUKT((C3:C6="71200384") *(B3:B6=29011047)*(F3:F6));WENNFEHLER(SVERWEIS("71200384";Rechnungsübersicht!C3:E5;2;0);""))
Gruß Hajo
AW: Fehler
18.03.2017 10:43:13
kathy
Hallo Hajo,
ich habe die Formel entsprechend angepasst, es kommt aber immer WERT raus.
=WENN(SUMMENPRODUKT((Tabelle7[Rechnungsnr.]=[@[Rechnungsnummer]]) *(Tabelle7[Gast-Nr]=[@[Gast-Nummer]]))0;SUMMENPRODUKT((Tabelle7[Rechnungsnr.]=[@[Rechnungsnummer]]) *(Tabelle7[Gast-Nr]=[@[Gast-Nummer]]));WENNFEHLER(SVERWEIS([@[Rechnungsnummer]];Tabelle7;12;0);""))
Wo liegt der Fehler?
Gruß kathy
Anzeige
AW: Fehler
18.03.2017 10:45:28
Hajo_Zi
Hallo Kathy,
dazu kann ich nichts schreiben, was wohl daran liegt, das ich die Datei nicht sehe.
Gruß Hajo
AW: Fehler
18.03.2017 11:05:02
Hajo_Zi
Hallo Kathy,
die Rechnungsnummer gibt es nicht in der 2 Tabelle darum ""

Rechnungsübersicht
 F
3Falsch
4Falsch
5Falsch

verwendete Formeln
Zelle Formel Bereich N/A
F3:F5=C3="71200372"  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.04 einschl. 64 Bit


Gruß Hajo
Anzeige
AW: Fehler
18.03.2017 11:11:24
kathy
Dann soll der Rechnungsbetrag aus der Gästeliste übernommen werden.
Gruß kathy
AW: Fehler
18.03.2017 11:12:29
Hajo_Zi
Hallo Kathy,
Ich erstelle die Lösung für das was im Beitrag dargestellt wurde.
Wird diese Darstellung geändert, überlasse ich anderen die Lösung, da ich schon eine Lösung erstellt hatte und dafür Zeit investiert habe.
Ich arbeite nicht für den Papierkorb.
Gruß Hajo
AW: Fehler
18.03.2017 11:19:37
Werner
Hallo Kathy,
dann am Ende der Formel anstatt
...$E$5;3;0);""))
das
...$E$5;3;0);D5))
Gruß Werner
Danke
18.03.2017 11:30:21
kathy
Hallo Werner,
vielen Dank.
Jetzt passt es.
Gruß kathy
Anzeige
Gerne u. Danke für die Rückmeldung. o.w.T.
18.03.2017 11:42:02
Werner

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige