Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
156to160
156to160
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

summe mit 2 bedingungen in excel

summe mit 2 bedingungen in excel
10.09.2002 10:13:59
sarah
hy leute!
kann mir jemand helfen?
in Spalte A stehen rechnernummern in B die Startzeit in C Stopzeit und in D das Delta zwischen B und C

Rechner Startdatum Enddatum Ausfall

AUGLMS01 1.9.02 23:30 2.9.02 1:30 2:00:00 +
AUGLMS19 2.9.02 3:30 2.9.02 4:15 0:45:00
AUGLMS18 3.9.02 20:30 4.9.02 3:45 7:15:00
AUGLMS01 4.9.02 13:15 4.9.02 18:30 5:15:00 +
AUGLMS20 3.10.02 16:12 3.10.02 17:15 1:03:00
AUGLMS01 6.10.02 7:38 6.10.02 9:24 1:46:00
AUGLMS15 15.11.02 13:45 15.11.02 13:59 0:14:00
AUGLMS01 29.11.02 18:14 29.11.02 19:01 0:47:00 +

nun soll der monatliche Ausfall des rechners 01 ausgerechnet werden.
Gibt es dafür eine Funktion die das Datum automatisch erkennt und nur die Ausfallwerte von AUGLMS01 im September errechnet?
SUMME AUGLMS01 (Sep.) = ?

mfg
sarah

17
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
summe mit 2 bedingungen
10.09.2002 10:27:50
WF
Hi sarah,

=SUMMENPRODUKT((A1:A100="AUGLMS01")*(MONAT(B1:B100)=9)*D1:D100)

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite mit Suchfunktion

Re: summe mit 2 bedingungen
10.09.2002 13:52:20
sarah
hi danke für die formel aber excel nimmt die bei mir nicht an
weisst du vielleicht warum?
sarah
Re: summe mit 2 bedingungen
10.09.2002 14:01:49
M@x
Hi Sarah,
bekommst du ein eFehlermeldung, ein Falsches Resultat oder ???

Gruss

M@x

Re: summe mit 2 bedingungen
10.09.2002 14:04:48
sarah
ja bei mir kommt der Fehlerwert #NAME?
Gruss
sarah
keinen Schimmer
10.09.2002 14:05:00
WF
Hi Sarah,

das ist eine ganz normale Formel.
Hast Du sie richtig abgeschrieben/kopiert?
Ist die Bezeichnung AUGLMS01 richtig (hinten 01 - NullEins)?

Salut WF

Anzeige
Re: keinen Schimmer
10.09.2002 14:07:17
sarah
ja ich hab sie richtig abgeschrieben das 01 hinten stimmt auch
sarah
Geht doch...
10.09.2002 14:10:30
Boris
Und schon bist du wieder im Gespräch...
Spar dir zukünftig bitte diesen Foren-Rundumschlag.
Und formuliere genauer. Ein Hinweis mit dem Fehlerwert #NAME
ist doch schnell in der Antwort formuliert...

Boris

Re: summe mit 2 bedingungen
10.09.2002 14:19:32
M@x
Hi Sarah,
etweder du hast dich vetippt oder in den Daten ist irgendwo ein Falsches Format in der Formel liegt der Fehler sicher nicht

Gruss

M@x

Re: summe mit 2 bedingungen
10.09.2002 14:21:11
sarah
der Fehler war, dass es ein falsches Format war
mfg
sarah
Du hast was falsch geschrieben!
10.09.2002 14:23:55
WF
Wenn Du, wie Du M@x geschrieben hast, den Fehlerwert #NAME? erhältst, dann ist entweder SUMMENPRODUKT oder MONAT falsch geschrieben bzw. AUGLMS01 steht nicht in Anführungszeichen.
Eine andere Möglichkeit gibt es nicht.
Anzeige
Re: Du hast was falsch geschrieben!
10.09.2002 14:26:02
sarah
ich hab zu erst den Fehlerwert #NAME? und dann #WERT! erhalten
mfg
sarah
in den Spalten B und D darf .....
10.09.2002 14:39:01
WF
Hi Sarah,

jetzt ham' wir's!

..... kein Text vorkommen, da multipliziert wird.

Mit Text mußt Du folgende Array-Formel verwenden:
{=SUMME(WENN((A1:A100="AUGLMS01");WENN(MONAT(B1:B100)=9;D1:D100)))}

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

trapp, trapp, trapp, trapp, trapp, brrrrr
WF


http://www.excelformeln.de/
die ultimative Formelseite

test
10.09.2002 15:47:34
snickers
ich versteh die Welt nicht mehr:-))
10.09.2002 20:25:54
Berai
Hallo WF,

bei Spotlight habe ich versucht deine Ehre zu retten und jetzt fällst du um :-))

http://spotlight.de/zforen/mse/m/mse-1031665129-14469.html

Bei mir hat SUMMENPRODUKT() funktioniert, so wie du es geschrieben hast.

Gruß
Rainer

Anzeige
SUMMENPRODUKT geht da auch
10.09.2002 21:20:57
Josef B
Hallo Excel Gemeinde

Die Formel:
=SUMMENPRODUKT((A1:A100="AUGLMS01")*(MONAT(B1:B100)=9)*D1:D100)
funktioniert so nicht, wenn in D1:D100 Text vorkommt.

Aber jetzt kommt der Hammer.
SummenProdukt in zwei Matrixen aufteilen und schon gehts:
=SUMMENPRODUKT((A1:A100="AUGLMS01")*(MONAT(B1:B100)=9);D1:D100)

viele Grüsse

Josef

kein Umfaller
11.09.2002 00:05:38
WF
Hi Rainer,

wenn in Spalte B nur ein Wert nachgefragt wird, ist eine Multiplikation von Wahrheitswerten kein Problem (0 oder 1); - wird da aber was mathematisches nachgefragt ....monat(Datum)=9 geht's, wenn da Text vorkommt immer in die Hose; - bei den verschachtelten WENNs nur, wenn auch die Bedingung in A zutrifft.

Back to the roots:
WENN benutze ich kaum noch; - sondern fast nur noch Multiplikationen von WAHR oder FALSCH - bei Text aber kann das tödlich sein!

Gruß WF

Anzeige
Re: kein Umfaller
11.09.2002 06:43:31
Berai
Hallo WF,

ich habe deine Begründung nie angezweifelt da mir diese auch bekannt ist, nur war in Sarah's Frage nie die Rede von Text in Spalte B oder C.
Nur deshalb beharrte ich auf meinem Standpunkt.

Gruß
Rainer


357 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige