Microsoft Excel

Herbers Excel/VBA-Archiv

sverweis mit 2 Variablen


Betrifft: sverweis mit 2 Variablen von: Andr. Ih.
Geschrieben am: 10.10.2017 21:45:52

Hallo Excel-Community,

ich habe mir eine große Tabelle aufgebaut, alles klappt soweit, nun scheitere ich aber an einer Formel, die ich zu Beginn wohl unterschätzt habe.

Ich würde gerne über einen sverweis einen Wert in einer Spalte ausgeben, wenn in zwei anderen Spalten zwei Variablen übereinstimmen.

Könnt ihr mir helfen das zu lösen?
Vielen Dank.
Andreas

  

Betrifft: Beispielmappe bitte von: Werner
Geschrieben am: 10.10.2017 21:52:27

Hallo Andreas,

und wer soll mit so allgemeinen Angaben etwas anfangen? Lad doch mal eine Beispielmappe hoch.

Gruß Werner


  

Betrifft: AW: sverweis mit 2 Variablen von: Daniel
Geschrieben am: 10.10.2017 21:52:44

Hi
die einfachste Variante ist, eine Hilfsspalte einzufügen und in dieser Hilfsspalte per Formel die Werte aus den zwei Spalten zu einem Wert zusammenzusetzen (=A1&B1) und diese Spalte dann als Suchspalte für den SVerweis zu verwenden.

Gruß Daniel


  

Betrifft: Schon möglich... von: Frank Furter
Geschrieben am: 10.10.2017 21:52:58

Hallo Andreas, du schreibst:"... Könnt ihr mir helfen das zu lösen?"


  

Betrifft: AW: sverweis mit 2 Variablen von: Andr. Ih.
Geschrieben am: 10.10.2017 22:24:45

Ich glaub meinen letzten Beitrag hat es nicht gepostet.
Ich benötige die den Preis, wenn die Teile-Nr. sowie das Land übereinstimmen.

Danke schon mal.

https://www.herber.de/bbs/user/116862.xlsx


  

Betrifft: AW: sverweis mit 2 Variablen von: Frank Furter
Geschrieben am: 10.10.2017 22:31:51

Hallo, eine Möglichkeit (erste Fundstelle bei einer Kombination)..:

=INDEX(E2:E7;VERGLEICH(G2&"*"&H2;INDEX(A2:A7&"*"&C2:C7;0)))

Wenn es nicht mehrere gleiche Kombinationen gibt, geht auch..:

=SUMMEWENNS(E2:E7;A2:A7;G2;C2:C7;H2)


  

Betrifft: AW: sverweis mit 2 Variablen von: Andr. Ih.
Geschrieben am: 10.10.2017 22:33:30

Danke, probiere ich gleich mal aus.
Wenn es klappt - einen schönen Abend euch :o)


Beiträge aus den Excel-Beispielen zum Thema "sverweis mit 2 Variablen"