Live-Forum - Die aktuellen Beiträge
Datum
Titel
15.07.2024 16:00:57
15.07.2024 15:41:38
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
SUMMEWENN; Zahl finden
12.09.2008 12:02:00
Cordula
Hallo Excel-Forum,
stehe gerade völlig auf dem Schlauch. Folgendes:
Spalte A
Artikel
210
e-6
s-9
310 1
Spalte B
Preis
10€
20€
30€
40€
Nun möchte ich nur den Preis summieren, deren Artikelnummer die erste Stelle eine Zahl ist. Da der Artikel 310 leer 1 nicht als Zahl erkannt wird, kann ich hier ja nicht mit ISTZAHL arbeiten.
Wäre toll, wenn Ihr eine Lösung hättet. In der Recherche finde ich nur das suchen/finden auf bestimmte Zeichen und das hilft mir hier nicht weiter.
Danke schon einmal im voraus
Gruß
Cordula

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: SUMMEWENN; Zahl finden
12.09.2008 12:07:00
Rudi
Hallo,
so:
=SUMMENPRODUKT(ISTZAHL(LINKS(A2:A5;1)*1)*B2:B5)
Gruß
Rudi
Puuuh - PERFEKT!
12.09.2008 12:12:00
Cordula
Hallo Rudi,
vielen vielen Dank für die suuuper schnelle Antwort. Klappt wunderbar. Wenn du Zeit hast, kannst du mir dann erklären was ;1)*1) bedeutet? Also, ich denke eine 1 wird für die 1. Stelle sein, aber welche ;-)
Danke dir schon einmal
Gruß
Cordula
AW: Puuuh - PERFEKT!
12.09.2008 12:38:00
Rudi
Hallo,
Links(A2:A5;1) ergibt immer einen Text. durch *1 soll dieser in eine Zahl umgewandelt werden.
Das klappt oder klappt nicht. Mit ISTZAHL(LINKS(A2:A5;1)*1) wird das geprüft und ergibt WAHR oder FALSCH bzw. 1 oder 0.
Gruß
Rudi
Anzeige
@ Rudi = KLASSE!!!!! o.T
12.09.2008 12:51:07
Cordula
...
AW: SUMMEWENN; Zahl finden
12.09.2008 12:15:00
65536
Hallo C.
für Deine Herausforderung gibt es soviele Möglichkeiten:
Beispiel:
Anstatt die Artikel Nr. in ein Zelle zuschreiben, schreib die Artikel-Nr in getrennte Spalten und füge eine weiter Spalte hinzu die, die Artikel-Nr (Duch die Formel-Verkettung) wieder zusammenfürhrt.
Somit kannst Du filter, sortieren ganz nach belieben
Das ist nur eine von vielen Möglichkeiten
Gruß 65536

313 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige