Herbers Excel-Forum - das Archiv

zählen von Zellen mit unterschiedlichem Inhalt

Bild

Betrifft: zählen von Zellen mit unterschiedlichem Inhalt
von: Michael

Geschrieben am: 23.02.2005 18:09:46
Hallo,
mein Problem ist doch noch nicht endgültig gelöst. Möchte Anzahl Lieferanten zählen:
Habe eine Anzahl Lieferantennummern in den Feldern A10:A30 von denen einige gleich sind, da sie verschiedenen Produktgruppen zugeordnet sind (s.u.).
Habe eine Anzahl Firmen die mit diesen Lieferanten Umsätze haben in den Feldern B9:E9. F9 ist Umsatz gesamt.
Einige Lieferanten haben keinen Umsatz mit irgendeiner Firma, andere haben Umsatz bei einigen, wieder andere haben Umsatz mit allen Firmen.
Die Lieferanten sind in Feldern F10:F30 verschiedenen Produktgruppen zugeordnet (Elektronik, Kunststoff, usw.)
Die Anzahl der Lieferanten (Felder B6:E6) soll nur die Anzahl zeigen bei denen die Firmen auch Umsatz haben.
Diese soll auch funktionieren wenn in Spalte "Produktgruppe" durch Autofilter eine bestimmte Produktgruppe herausgefiltert wird.
hmm, ist das so nachvollziehbar??
"{=SUMME(1/ZÄHLENWEN"A5:A9;A5:A9)}" alleine merkt nicht dass z.B. Lieferant "6" keinen Umsatz bei irgendeiner Firma hat... Was kann ich tun??
Please help me!!
Michael
(zweites Problem, ich weiss nicht wie man ins Forum eine kleine Beispieltabelle beifügen kann...)
Bild

Betrifft: AW: zählen von Zellen mit unterschiedlichem Inhalt
von: HermannZ

Geschrieben am: 23.02.2005 18:50:49
hallo Michael,
kannst du nicht ein Beispiel hochladen,durch deine Beschreibung blicke ich nicht ganz durch.
Zu deiner Frage;
gehe auf durchsuchen-- Datei anklicken-- Datei zum Server --- im Fenster den Link kopieren und in dein Posting einfügen fertig.
Gruß hermann
Bild

Betrifft: AW: zählen von Zellen mit unterschiedlichem Inhalt
von: Michael
Geschrieben am: 24.02.2005 08:40:41
hallo hermann,
hatte nur einen ungültigen namen für den file vergeben...
hilfe wäre toll.
gruss,
Michael
https://www.herber.de/bbs/user/18645.xls
Bild

Betrifft: AW: zählen von Zellen mit unterschiedlichem Inhalt
von: Michael
Geschrieben am: 24.02.2005 08:53:55

upps, war doch noch kleiner fehler in beispiel... Michael
https://www.herber.de/bbs/user/18647.xls
 Bild
Excel-Beispiele zum Thema "zählen von Zellen mit unterschiedlichem Inhalt"
Makros in Abhängigkeit vom Zellennamen aufrufen Zellen auf Kommentar überprüfen
Spalten bedingt summieren und Zellen formatieren Text aus Textbox in Zellen aufteilen
Zellen vergleichen und markieren Zählen formatierter Zellen
Daten aus Textdatei gezielt in Zellen übernehmen Zellen verbinden und trennen
Zellen bei Minuswerten schraffieren Zeilen oberhalb der markierten Zellen einfügen