Live-Forum - Die aktuellen Beiträge
Datum
Titel
25.06.2024 22:07:02
25.06.2024 21:01:55
25.06.2024 19:21:44
Anzeige
Archiv - Navigation
1108to1112
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Sverweis. Bei "0-Wert" eine Ergebnis ausblenden

Sverweis. Bei "0-Wert" eine Ergebnis ausblenden
Werner
Guten Abend die Damen und Herren,
dank Eurer Hilfe (wie immer superschnell und gut) konnte ich meine Benotungen mit Sverweis automatisieren.
Jetzt stellt sich mir ein weiteres Problem.
Meine Tabelle errechnet in der Spalte W die Gesamtpunkte aus den Spalten A-V, errechnet in der Spalte
X den Notendurchschnitt und gibt dann in der Spalte Z die Note (Aus der Vorlagentabelle) aus.
https://www.herber.de/bbs/user/65211.xls
Mir wäre nun gehlfen wenn jemand einen Tipp hat wie ich das ungenügend in der Spalte Z entfernen kann, wenn A-V ohne Wert ist!
Vielen Dank für Eure Hilfe im Voraus!
DerWerner

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Sverweis. Bei "0-Wert" eine Ergebnis ausblenden
19.10.2009 22:20:27
Josef
Hallo Werner,
Ergebnis

 ABCDEFGHIJKLMNOPQRSTUVWXYZAAABACAD
2I1I2I3II1II2II3II4II5II6II7II8II9II10III1III2III3III4IV1IV2IV3IV4IV5Allg.Ø Allg.Note Allgemein (17)FührungØ FührungNote Führung (5)Ø GesamtNote Gesamt (21)
3                              
4               85   25  855,000sehr gut255sehr gut5,000sehr gut
5               85      855,000sehr gut00 3,864vb
6               84      844,941gut o. G.00 3,818vb
7               80      804,706gut00 3,636vb u. G.
8               75      754,412gut u. G.00 3,409befr. o. G.
9                      00,000 00 0,000 
10                      0  0  0,000 
11                      0  0  0,000 
12                      0  0  0,000 
13                      0  0  0,000 
14                      0  0  0,000 
15                      0  0  0,000 
16                      0  0  0,000 
17                      0  0  0,000 

Formeln der Tabelle
ZelleFormel
Y4=WENN(ANZAHL(A4:V4)=0;"";INDEX(vorlage!$A$1:$A$15;VERGLEICH(X4;vorlage!$D$1:$D$15;-1)))
Z4=SUMME(R4:V4)
AA4=SUMME(Z4/5)
AB4=WENN(ANZAHL(R4:V4)=0;"";INDEX(vorlage!$A$1:$A$15;VERGLEICH(AA4;vorlage!$D$1:$D$15;-1)))
AC4=(W4+Z4)/22
AD4=WENN(AC4=0;"";INDEX(vorlage!$A$1:$A$15;VERGLEICH(AC4;vorlage!$D$1:$D$15;-1)))

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
Y41. / Formel ist =X4=""Abc
Y42. / Formel ist =ODER(Y4="sehr gut")Abc
Y43. / Formel ist =ODER(Y4="gut o. G.";Y4="gut";Y4="gut u. G.")Abc
AB41. / Formel ist =AA4=""Abc
AB42. / Formel ist =ODER(AB4="sehr gut")Abc
AB43. / Formel ist =ODER(AB4="gut o. G.";AB4="gut";AB4="gut u. G.")Abc
AD41. / Formel ist =AC4=""Abc
AD42. / Formel ist =ODER(AD4="sehr gut")Abc
AD43. / Formel ist =ODER(AD4="gut o. G.";AD4="gut";AD4="gut u. G.")Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp

Anzeige
AW: Sverweis. Bei "0-Wert" eine Ergebnis ausblenden
19.10.2009 22:26:16
Werner
Hallo Sepp!
Das sieht super aus....wie immer unglaublich schnell und gut!!
Ich werde mich jetzt noch ein wenig ins Verstehen begeben aber das ist genau das was ich haben wollte!!
Danke vielmals!!
DerWerner
AW: Sverweis. Bei "0-Wert" eine Ergebnis ausblenden
19.10.2009 23:23:40
Werner
Ich habs verstanden!
Danke....supergut!

313 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige