Microsoft Excel

Herbers Excel/VBA-Archiv

Vergleich 0 statt Leer

Betrifft: Vergleich 0 statt Leer von: Anna
Geschrieben am: 28.09.2020 15:56:24

Hallo

Ich habe ein problem bei einer Formel

Kann mir bitte einer weiter helfen?

Bei Tabelle 1 kommt immer eine 0 statt das die Zelle leer bleibt
=INDEX(Tabelle2!K:K;VERGLEICH(K26;Tabelle2!A:A))

Damit hat es auch nicht funktioniert
=WENN(Tabelle2!K="";"";INDEX(Tabelle2!K:K;VERGLEICH(K26;Tabelle2!A:A)))

Betrifft: AW: das ist aus Sicht Excel so korrekt ...
von: neopa C
Geschrieben am: 28.09.2020 16:03:03

Hallo Anna,

... wenn kein Wert in Tabelle2!K:K in der durch Vergleich gefundenen Zelle steht, dann gibt INDEX() eine 0 als Ergebnis aus. Das kann man auf verscheide Arten abfangen, wenn keine 0 ausgegeben werden soll. Dein WENN()-Konstrukt ist jedoch ungeeignet.

Stehen in Tabelle2!K:K zahlen- oder Textwerte? Kann auch ein echter 0-Wert in Tabelle2!K:K stehen?

Gruß Werner
.. , - ...

Betrifft: AW: das ist aus Sicht Excel so korrekt ...
von: Anna
Geschrieben am: 28.09.2020 16:13:21

Hallo Werner

Also in Tabelle2 K stehen Postfächer drin
z.B. K1 steht Postfach 140 und in K2 steht nichts drin

ich will das dann auch nichts in Tabelle1 steht
Aber es kommt dann immer die 0

Betrifft: AW: ein Möglichkeit wäre ...
von: neopa C
Geschrieben am: 28.09.2020 16:36:51

Hallo Anna,

... formatiere die Ergebniszellen mit dem benutzerdefinierten Zahlenformat: 0;; Da bleibt das Zahlenformat für die Postfachnummer erhalten und die Ergebnis-0-Werte sind unsichtbar.

Da Du aber wahrscheinlich nicht mit der Postfachnummer weiter rechnen musst, wäre der Vorschlag von Rudi eine gute Alternative. Soll jedoch das das Zahlenformat beibehalten bleiben aber da wo eine 0 ermittelt wird diese nicht entstehen, sondern ein "", dann z.B. so:

=WENNFEHLER(1/(1/[Deine INDEX-Formel]);"")

Gruß Werner
.. , - ...

Betrifft: AW: ein Möglichkeit wäre ...
von: Anna
Geschrieben am: 28.09.2020 16:54:47

Hallo Werner

Meinst DU so...

=WENNFEHLER(1/(1/[INDEX(Tabelle2!K:K;VERGLEICH(K26;Tabelle2!A:A))];"")

funktioniert nicht

Betrifft: AW: in Deiner Formel musst Du [] weglassen owT
von: neopa C
Geschrieben am: 28.09.2020 17:22:13

Gruß Werner
.. , - ...

Betrifft: AW: ein Möglichkeit wäre ...
von: Anna
Geschrieben am: 28.09.2020 19:05:54

Hallo Werner

Ich weiß nicht was ich falsch mache aber wenn ich jetzt diese Formel eigebe, dann bleibt das fällt jetzt auch leer selbst wenn in Tabelle2 ein Eintrag steht

=WENNFEHLER(1/(1/INDEX(Tabelle2!K:K;VERGLEICH(K26;Tabelle2!A:A)));"")

Betrifft: AW: sind denn die Einträge auch Zahlenwerte? owT
von: neopa C
Geschrieben am: 28.09.2020 19:24:12

Gruß Werner
.. , - ...

Betrifft: AW: das 3. Argument für VERGLEICH() fehlt ...
von: neopa C
Geschrieben am: 28.09.2020 19:37:30

Hallo Anna,

... und die Klammersetzung war auch noch nicht korrekt.

Wenn die Ergebniswerte Zahlenwerte sind und das 3. Argument (das FALSCH oder die 0, wie ich es nutze) für VERGLEICH() nicht bewusst weggelassen wurde, dann führt folgende Formel zum angestrebten:

=WENNFEHLER(1/(1/INDEX(Tabelle2!K:K;VERGLEICH(K26;Tabelle2!A:A;0)));"")

Gruß Werner
.. , - ...

Betrifft: &"" hinten dran. owT
von: Rudi Maintaire
Geschrieben am: 28.09.2020 16:05:23



Betrifft: AW: Zahlenwerte werden so aber zu Textwerten owT
von: neopa C
Geschrieben am: 28.09.2020 16:11:35

Gruß Werner
.. , - ...

Betrifft: weiß ich doch. owT
von: Rudi Maintaire
Geschrieben am: 29.09.2020 12:45:04



Betrifft: AW: klar, war ja auch nur Hinweis für den TE owT
von: neopa C
Geschrieben am: 29.09.2020 13:51:23

Gruß Werner
.. , - ...