Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl leere Zellen, aber nicht in derselben Zeile

Betrifft: Anzahl leere Zellen, aber nicht in derselben Zeile von: Kerstin Newcomer
Geschrieben am: 15.11.2004 10:48:25

Hallo,
vielleicht hat jemand einen Tip für mich.
Ich möchte die Anzahl leerer Zellen in einem Bereich zählen (A2:B200), aber wenn zum Beispiel A5 und B5 leer sind, so soll nur einmal gezählt werden (egal A5 oder B5).
Vielen Dank
Kerstin

  


Betrifft: AW: Anzahl leere Zellen, aber nicht in derselben Zeile von: Frank
Geschrieben am: 15.11.2004 10:52:27

Hi Kerstin
=SUMMENPRODUKT(--((A2:AA200="")+(B2:B200="")>0))

Frank


  


Betrifft: AW: Anzahl leere Zellen, aber nicht in derselben Z von: Kerstin
Geschrieben am: 15.11.2004 11:21:59

Hallo Frank!
Danke,
funktioniert aber irgendwie nicht: #NAME!
Was macht >0
und was bedeuted -- ?
Sollte man nicht irgendwie WENN(UND(A2="";B2=""); ...verknüpfen?
Ich weiß auch nicht,
aber Danke
Kerstin


  


Betrifft: AW: Anzahl leere Zellen, aber nicht in derselben Z von: Frank
Geschrieben am: 15.11.2004 11:27:41

Hi Kerstin
wenn Du ein deutsches Excel cerwendest, sollte die Formel funktionieren. Poste doch mal die exakte Formel, die Du versucht hast.

Zur Erklärung dieser Syntax siehe:
http://www.xldynamic.com/source/xld.SUMPRODUCT.html

Frank


  


Betrifft: AW: Anzahl leere Zellen, aber nicht in derselben Z von: poste Formel
Geschrieben am: 15.11.2004 12:09:20


Hallo Frank,
anbei mein Versuch:

https://www.herber.de/bbs/user/13489.xls

Ps.: Danke,
Kerstin


  


Betrifft: AW: Anzahl leere Zellen, aber nicht in derselben Zeile von: HermannZ
Geschrieben am: 15.11.2004 12:34:46

Hallo Kerstin,

wenn ich das richtig verstanden habe dann so,

"=ZÄHLENWENN(A2:B248;"")-SUMMENPRODUKT((A2:A248="")*(B2:B248=""))"

Gruß hermann


  


Betrifft: AW: Anzahl leere Zellen, aber nicht in derselben Z von: Kerstin
Geschrieben am: 15.11.2004 12:53:29

Perfekt!
Super, Danke,
so funktioniert´s!
Gruss
Kerstin


  


Betrifft: AW: Danke für die Rückmeldung oT. von: HermannZ
Geschrieben am: 15.11.2004 13:01:19

.


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl leere Zellen, aber nicht in derselben Zeile"