Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
896to900
896to900
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Pivtabelle / Anzahl; Zelle nicht leer?!?

Pivtabelle / Anzahl; Zelle nicht leer?!?
15.08.2007 16:18:21
backi
Problem bei Pivottabelle (Anzahl)
ich möchte mittels Pivottabelle die anzahl von werten einer tabelle auflisten lassen:
soweit kein problem, mein problem besteht darin, das in der tabelle nicht nur zahlen, sondern auch formeln stehen, und diese formeln zählen als wert, auch wenn das feld leer ist:
beispiel:
in einem feld2 steht: WENN (Feld1<10;Feld1;"") (Feld1 ist aber größer als 10)
optisch und theoretisch ist feld2 leer, da feld1 größer10 ist
wenn ich jetzt aber eine pivot über feld2 lege und mir die anzahl ausgeben lasse müsste ich eigentlich "0" oder "leer" bekommen, aber ich erhalte "1". vermutlich weil die formel in dem feld steht, und die zelle somit gefüllt ist.
kann ich das abschalten und nur den reinen mathematischen inhalt in der pivot verarbeiten?

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Pivtabelle / Anzahl; Zelle nicht leer?!?
16.08.2007 07:28:48
Werner
Hallo backi,
ich würde ein zusätzliches Feld aufnehmen, welches den Wert 1 oder 0 (wahr oder falsch) annimmt.
Dann kannst Du anstatt "Anzahl" die entsprechende "Summe" bilden.
Da eine Wertetabelle aus Datensätzen besteht, sind auch leere Felder Datensätze.
Wertetab

 ABC
1Spalte1Spalte2JNSpalte2
2111
3221
411 0
5991

Formeln der Tabelle
ZelleFormel
B2=WENN(A2<10;A2;"")
C2=N(B2=A2)
B3=WENN(A3<10;A3;"")
C3=N(B3=A3)
B4=WENN(A4<10;A4;"")
C4=N(B4=A4)
B5=WENN(A5<10;A5;"")
C5=N(B5=A5)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
in der/den Pivottabelle/n sieht das dann wie folgt aus:
Pivottab

 ABCD
1Spalte1(Alle)  
2Spalte2(Alle)  
3    
4Summe - JNSpalte2Ergebnis  
5Ergebnis27-->nicht Anzahl, sondern Summe
6    
7    
8    
9    
10Spalte1(Alle)  
11Spalte2(Alle)  
12    
13Anzahl - JNSpalte2Ergebnis  
14Ergebnis36-->Anzahl zählt alle Datensätze, auch leere.


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Werner

Anzeige
AW: Pivtabelle / Anzahl; Zelle nicht leer?!?
16.08.2007 13:19:00
backi
Prima, das ist ein Lösungsansatz.
Danke.

335 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige