Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
556to560
556to560
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

summenprodukt mit text

summenprodukt mit text
31.01.2005 19:42:03
stefan_s
hallo spezialisten,
ich möchte monatsbezogen die werte aus spalte b summieren
ich habe in spalte a das datum und in spalte b die werte, allerdings ist auch hin und wieder ein text in spalte b und ich erhalte dann den fehler #wert bei dieser formel:
=SUMMENPRODUKT((MONAT(A1:A100)=1)*(B1:B100))
bitte um hilfe, wie ich diesen fehler umgehen kann.
besten dank

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: summenprodukt mit text
31.01.2005 20:27:27
Josef
Hallo Stefan!
Probier mal:
=SUMMENPRODUKT((MONAT(A1:A100)=1)*(ISTZAHL(B1:B100));(B1:B100))
Gruß Sepp
P.S.: Rückmeldung nicht vergessen!
AW: summenprodukt mit text
31.01.2005 20:36:02
stefan_s
Hallo Sepp,
vielen lieben Dank für deine Unterstützung. Funktioniert genau wie gewollt.
Endlich wieder schlaf für mich :-)
Dank&Gruß, Stefan
AW: summenprodukt mit text
Hübi
Hi Stefan,
probier das mal aus
Tabelle1
 ABCD
101.01.2005100 Summe
202.01.200550 350
303.03.2005100  
431.01.2005200  
517.01.2005otto  
6    
Formeln der Tabelle
D2 : {=SUMME(WENN(MONAT(A1:A10)=1;B1:B10;0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Hübi
Anzeige
AW: summenprodukt mit text
31.01.2005 20:46:06
stefan_s
Hallo Hübi,
auch dir den besten Dank. Echt Super, jetzt hab ich auch gleich 'ne Lösung mit einer Matrixformel. Funktioniert ebenfalls wie gewünscht.
Dank&Gruß, Stefan
AW: summenprodukt mit text
Luc
Hallo meine Herren,
und hier überflüssigerweise noch die 3.Variante
{=SUMMENPRODUKT((MONAT(A$1:A$100)=ZEILE(1:1))*(WENN(ISTZAHL(B$1:B$100);(B$1:B$100);0)))}
mit der Besonderheit, dass sie über 12 Zeilen gezogen wdn kann und so für jeden Monat bereitsteht. Anschließend muss aber jede einzelne für sich zur Matrixformel gemacht wdn.
Gruß Luc
AW: summenprodukt mit text
31.01.2005 20:52:33
stefan_s
Hallo Luc,
vielen Dank für die Zusatzinfo, kann ich bestimmt in naher Zukunft gebrauchen.
Dank&Gruß, Stefan
Anzeige
Geht auch ohne die { }
Boris
Hi Luc,
Anschließend muss aber jede einzelne für sich zur Matrixformel gemacht wdn.
Nicht nötig.
=SUMMENPRODUKT((MONAT(A$1:A$100)=ZEILE(A1))*ISTZAHL(B$1:B$100);B$1:B$100)
und runterkopieren.
Grüße Boris
richtig Boris, war schon bei Sepp - owT
Luc

325 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige