Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Textwert und Zahl mit Summenprodukt

Textwert und Zahl mit Summenprodukt
karl
Hallo liebe Excelfreunde,
ich verwende die Summenprodukt Formel um in einer extern verknüpften Datei Werte auszulesen. Mein Problem ist nur dass sich die Vergleichswerte in Inhalt und Format unterscheiden, sprich:
- die Bezugsmatrix hat Zahlenwerte als Text mit einigen NULLEN vorangestellt: 00001
- der Vergleichswert ist ne ganz normale Zahl: 1
'SUMMEWENN' hat damit kein Problem und interpretiert Text = 00001 als Zahl = 1, jedoch kann die SUMMEWENN nicht auf externe Dateien verknüpfen.
Gibt's da ne Lösung damit auch SUMMENPRODUKT die Zahl als Text erkennt?
Wäre super dankbar!
GRüße
Karl

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
...=Text(Vergleichswert;"00000") owT
28.03.2011 12:25:20
Rudi
AW: ...=Text(Vergleichswert;"00000") owT
28.03.2011 12:36:48
karl
Kannst du mir sagen wie ich das genau in die Summenproduktformel einbaue?
=SUMMENPRODUKT(('[Quelle.xls]Tabelle1'!$B$2:$B$466=A6)*('[Quelle.xls]Tabelle1'!$C$2:$C$466))
...
B2 bis B466 beinhaltet die Zahlenwerte als Text !
A6 ist doch d.Vergleichswert! Oder? Xlgut? :-> orT
28.03.2011 13:12:11
Luc:-?
Gruß Luc :-?
AW: A6 ist doch d.Vergleichswert! Oder? Xlgut? :-> orT
28.03.2011 13:33:47
karl
Sorry A6 ist die Zahl, z.B. 3
und die Bezugsmatrix hat Textwerte drin, zB 0000003
will, dass summenprodukt die beiden werte vergleiche kann?
gibts da keine Lösung?
:'-(
...:$B$466=Text(A6;"00000"))*... Nun klar?! owT
28.03.2011 14:02:13
Luc:-?
:-?
Sprache verschlagen? ;-) Alternativ...
28.03.2011 14:59:52
Luc:-?
…gäbe es natürlich noch die Möglichkeit …--(…:$B$466=A6)*… zu schreiben, Karl,
wenn alle Daten in diesem Bereich Textzahlen sind. Aber da wir die Homogenität deiner Daten nicht einschätzen können, ist Rudi auf „Nummer sicher” gegangen.
Gruß Luc :-?
Anzeige

336 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige