Microsoft Excel

Herbers Excel/VBA-Archiv

Zellen mit Werten zählen | Herbers Excel-Forum


Betrifft: Zellen mit Werten zählen von: Werner
Geschrieben am: 11.11.2009 09:21:33

Hallo zusammen!

Ich suche jetzt seit 2 Tagen nach einer Lösung aber ich finde nichts (oder ich bin blind).

In Bereich B21 bis B200 stehen Namen.
Diese ziehe ich mit der Formel (z. B.) =AQ21 usw. aus einem anderen Bereich.
Zwischendurch sind auch mal Zeilen ohne Namen aber immer noch mit der Formel.
Ich möchte nun wissen, wieviele Namen in meiner Liste (Gesamtstückzahl) stehen.
Mit Anzahl2 zählt er alles. Auch die Formeln. Denn das ist ja auch Text.
Ich will aber nur die Zellen zählen lassen, die einen echten Wert, also den Namen eines Menschen, beinhalten.
Das muss doch machbar sein, oder?

Gruß und DANKE für eure Hilfe!

Werner

  

Betrifft: =ZÄHLENWENN(B21:B200;"<>0") ? oT von: Matthias L
Geschrieben am: 11.11.2009 09:29:32




  

Betrifft: AW: =ZÄHLENWENN(B21:B200;"<>0") ? oT von: Werner
Geschrieben am: 11.11.2009 09:32:51

Hallo Matthias!

Das hatte ich schon probiert. Es werden hier auch die Zellen gezählt, die nur die Formel enthalten.
Meine Zahl müsste 140 sein (so viele Leute haben ich in der Liste).
Das Ergebnis der Formel ist aber 180.

Gruß

Werner


  

Betrifft: vielleicht mit Zählenwenn... von: Tino
Geschrieben am: 11.11.2009 09:30:51

Hallo,
so müsste es doch gehen.

=ZÄHLENWENN(B21:B200;"<>")

Gruß Tino


  

Betrifft: Korrektur von: Tino
Geschrieben am: 11.11.2009 09:33:09

Hallo,
besser wäre

=ZÄHLENWENN(B21:B200;"*")

Gruß Tino


  

Betrifft: AW: Korrektur von: Werner
Geschrieben am: 11.11.2009 09:34:58

Hallo Tino!

Gleiches Problem wie bei meiner vorherigen Antwort.
Es werden auch die Formeln gezählt, die gar keinen echten Wert (also Namen eines Menschen) zurück geben.

Gruß

Werner


  

Betrifft: wieso.. Tino's Formel Gruß von: robert
Geschrieben am: 11.11.2009 09:41:47


Tabelle1

 ABC
2     
3a  a
4s  s
5d  d
6    0
7    0
8f  f
9g  g
10    0
11b  b
12n  n
13m  m
14k  k
15    0
16    0
17e  e
18d  d
19     
20    11

verwendete Formeln
Zelle Formel
C3 =A3
C4 =A4
C5 =A5
C6 =A6
C7 =A7
C8 =A8
C9 =A9
C10 =A10
C11 =A11
C12 =A12
C13 =A13
C14 =A14
C15 =A15
C16 =A16
C17 =A17
C18 =A18
C20 =ZÄHLENWENN(C3:C18;"*")

Tabellendarstellung in Foren Version 4.28




  

Betrifft: noch ein versuch... von: Tino
Geschrieben am: 11.11.2009 09:49:37

Hallo,

 CDEF
13 Name 1Name 1
2    
3  Name 3Name 3
4    
5  Name 5Name 5

Formeln der Tabelle
ZelleFormel
C1=ZÄHLENWENN(E1:E5;">*")
E1=WENN(F1<>"";F1;"")
E2=WENN(F2<>"";F2;"")
E3=WENN(F3<>"";F3;"")
E4=WENN(F4<>"";F4;"")
E5=WENN(F5<>"";F5;"")



Gruß Tino


  

Betrifft: AW: Zellen mit Werten zählen von: robert
Geschrieben am: 11.11.2009 09:34:32

hi,

und wenn du die spalte AQ zählst ?

gruß
robert


  

Betrifft: AW: Zellen mit Werten zählen von: Werner
Geschrieben am: 11.11.2009 09:39:43

ICH BIN SOOO BLÖD! ;-))

Die Daten werden in Spalte AQ aus einem anderen Blatt gezogen.
Ich musste nur mit
=ZÄHLENWENN(Mitarbeiter!C6:C195;"*")
die Namesliste im anderen Blatt zählen.

Sehr blamabel.
Entschuldigt das ich euch damit jetzt belästigt habe.
Manchmal sieht man den Wald vor lauter Bäumen nicht.

Gruß und DANKE für eure Hilfe!!!

Werner


  

Betrifft: AW: Zellen mit Werten zählen von: Sven
Geschrieben am: 11.11.2009 09:46:21

Wie wäre es, wenn Du beim Ziehen in Spalte B ein Negativereignis definierst, z. B. so

=WENN(AQ21="";"X";AQ21)

anschließend ziehst Du die Anzahl der Negativereignisse von der Gesamtzahl ab

=ZÄHLENWENN(B21:B200;"X")+Anzahl(B21:B200)

Ist zwar ein bisser aufwendiger, aber letztlich musst Du ja jede Formel nur einmal eingeben ... Vielleicht hilfts Dir ja.


Gruß, Sven


Beiträge aus den Excel-Beispielen zum Thema "Zellen mit Werten zählen"