Zahlen aus Zellen mit Buchstaben und Zahlen

Bild

Betrifft: Zahlen aus Zellen mit Buchstaben und Zahlen
von: Dori
Geschrieben am: 22.04.2015 10:39:05

Hallo zusammen,
Text in Spalten wäre hier eine Lösung, den Schritt möchte ich mir, bzw. meinen Kollegen, die später damit arbeiten müssen ersparen, jemand eine bessere Lösung?
Basis April

 AMANAOAPAQARASATAU
1fBezSummenAQPKUBEF
2 Summen: A 22     E 41,5     Q 41,25     V 159,5        
3 Summen: E 22     K 137,5     Q 6,25     V 159,5        
4 Summen: A 34     K 17     Q 50     U 8,5     V 159,5        
5 Summen: A 43     Q 23,25     U 42,5     V 159,5        
6 Summen: E 4     K 17     Q 36,25     U 34     V 86,5        
7 Summen: K 17     Q 2,75     V 17        
8 Summen: A 17     K 87     Q 10,5     V 159,5        


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß, Dori

Bild

Betrifft: AW: Zahlen aus Zellen mit Buchstaben und Zahlen
von: SF
Geschrieben am: 22.04.2015 11:05:44
Hola,
meinst du sowas hier?
http://www.excelformeln.de/formeln.html?welcher=326
Gruß,
steve1da

Bild

Betrifft: AW: Zahlen aus Zellen mit Buchstaben und Zahlen
von: Dori
Geschrieben am: 22.04.2015 12:12:12
Hallo Steve,
nein, das wäre ja auch mit Text in Spalten zu lösen.
Ich möchte die Werte hinter den Buchstaben in die jeweiligen Zellen rechts summieren.

Bild

Betrifft: AW: Zahlen aus Zellen mit Buchstaben und Zahlen
von: Matthias L
Geschrieben am: 22.04.2015 13:19:51
Hallo Dori
Hier ein Bsp aus dem Archiv, angepasst.
https://www.herber.de/bbs/user/97230.xlsm
Gruß Matthias

Bild

Betrifft: AW: Zahlen aus Zellen mit Buchstaben und Zahlen
von: Dori
Geschrieben am: 22.04.2015 15:18:54
Hallo Matthias,
etwas in der Art hatte ich auch schon gefunden, ist aber nicht das was ich suche...
Muss mich auch korrigieren, ich brauche keine Summierung, sondern ein Auslesen der Zahlen, die hinter den einzelnen Buchstaben stehen... in die Spalten rechts davon A, Q, P etc.

Bild

Betrifft: Beispieldatei?
von: Michael
Geschrieben am: 22.04.2015 15:53:37
Hallo Dori,
kannst Du bitte ne Datei hochladen? Aus Deiner Grafik geht nämlich nicht hervor, in welche Spalte die Zahlen von "V" gehören.
Abgesehen davon: nachdem Du Dich schon in Spalten rechts von AM bewegst, würde ich vermuten, daß die Ergebnisse "links" bereits irgendwo vorhanden sind und abgegriffen werden könnten.
Schöne Grüße,
Michael

Bild

Betrifft: AW: Beispieldatei?
von: Dori
Geschrieben am: 23.04.2015 09:20:46
Hallo Michael,
die Spalte V gehört natürlich auch dahin, klar!
Im Moment helfe ich mir so:
April

 PQRSTUVWXYZAAABACADAEAFAGAHAIAJAKALAMANAOAPAQARASAT
1fBezSummen                     AQPKUBEFV
2 Summen: A 22     E 41,5     Q 41,25     V 159,5 Summen:A22E41,5Q41,25V159,5           2241,250000420159,5
3 Summen: E 22     K 137,5     Q 6,25     V 159,5 Summen:E22K137,5Q6,25V159,5           06,25013800220159,5
4 Summen: A 34     K 17     Q 50     U 8,5     V 159,5 Summen:A34K17Q50U8,5V160         34500179000159,5
5 Summen: A 43     Q 23,25     U 42,5     V 159,5 Summen:A43Q23,25U42,5V159,5           4323,250043000159,5
6 Summen: E 4     K 17     Q 36,25     U 34     V 86,5 Summen:E4K17Q36,25U34V86,5         036,250173404086,5

Formeln der Tabelle
ZelleFormel
AL2{=SUMME(WENN($S2:$AI2="A";$T2:$AJ2))}
AM2{=SUMME(WENN($S2:$AI2="Q";$T2:$AJ2))}
AN2{=SUMME(WENN($S2:$AI2="P";$T2:$AJ2))}
AO2{=SUMME(WENN($S2:$AI2="K";$T2:$AJ2))}
AP2{=SUMME(WENN($S2:$AI2="U";$T2:$AJ2))}
AQ2{=SUMME(WENN($S2:$AI2="B";$T2:$AJ2))}
AR2{=SUMME(WENN($S2:$AI2="E";$T2:$AJ2))}
AS2{=SUMME(WENN($S2:$AI2="F";$T2:$AJ2))}
AT2{=SUMME(WENN($S2:$AI2="V";$T2:$AJ2))}
AL3{=SUMME(WENN($S3:$AI3="A";$T3:$AJ3))}
AM3{=SUMME(WENN($S3:$AI3="Q";$T3:$AJ3))}
AN3{=SUMME(WENN($S3:$AI3="P";$T3:$AJ3))}
AO3{=SUMME(WENN($S3:$AI3="K";$T3:$AJ3))}
AP3{=SUMME(WENN($S3:$AI3="U";$T3:$AJ3))}
AQ3{=SUMME(WENN($S3:$AI3="B";$T3:$AJ3))}
AR3{=SUMME(WENN($S3:$AI3="E";$T3:$AJ3))}
AS3{=SUMME(WENN($S3:$AI3="F";$T3:$AJ3))}
AT3{=SUMME(WENN($S3:$AI3="V";$T3:$AJ3))}
AL4{=SUMME(WENN($S4:$AI4="A";$T4:$AJ4))}
AM4{=SUMME(WENN($S4:$AI4="Q";$T4:$AJ4))}
AN4{=SUMME(WENN($S4:$AI4="P";$T4:$AJ4))}
AO4{=SUMME(WENN($S4:$AI4="K";$T4:$AJ4))}
AP4{=SUMME(WENN($S4:$AI4="U";$T4:$AJ4))}
AQ4{=SUMME(WENN($S4:$AI4="B";$T4:$AJ4))}
AR4{=SUMME(WENN($S4:$AI4="E";$T4:$AJ4))}
AS4{=SUMME(WENN($S4:$AI4="F";$T4:$AJ4))}
AT4{=SUMME(WENN($S4:$AI4="V";$T4:$AJ4))}
AL5{=SUMME(WENN($S5:$AI5="A";$T5:$AJ5))}
AM5{=SUMME(WENN($S5:$AI5="Q";$T5:$AJ5))}
AN5{=SUMME(WENN($S5:$AI5="P";$T5:$AJ5))}
AO5{=SUMME(WENN($S5:$AI5="K";$T5:$AJ5))}
AP5{=SUMME(WENN($S5:$AI5="U";$T5:$AJ5))}
AQ5{=SUMME(WENN($S5:$AI5="B";$T5:$AJ5))}
AR5{=SUMME(WENN($S5:$AI5="E";$T5:$AJ5))}
AS5{=SUMME(WENN($S5:$AI5="F";$T5:$AJ5))}
AT5{=SUMME(WENN($S5:$AI5="V";$T5:$AJ5))}
AL6{=SUMME(WENN($S6:$AI6="A";$T6:$AJ6))}
AM6{=SUMME(WENN($S6:$AI6="Q";$T6:$AJ6))}
AN6{=SUMME(WENN($S6:$AI6="P";$T6:$AJ6))}
AO6{=SUMME(WENN($S6:$AI6="K";$T6:$AJ6))}
AP6{=SUMME(WENN($S6:$AI6="U";$T6:$AJ6))}
AQ6{=SUMME(WENN($S6:$AI6="B";$T6:$AJ6))}
AR6{=SUMME(WENN($S6:$AI6="E";$T6:$AJ6))}
AS6{=SUMME(WENN($S6:$AI6="F";$T6:$AJ6))}
AT6{=SUMME(WENN($S6:$AI6="V";$T6:$AJ6))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Die Datenquelle ist ein dämlicher Excelexport aus einer Software, mit der wir arbeiten müssen.
Tabelle1

 DEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAGAHAIAJ
1fTmpAnwZuPersIdfTmpAnwStunde1fTmpAnwStunde2fTmpAnwStunde3fTmpAnwStunde4fTmpAnwStunde5fTmpAnwStunde6fTmpAnwStunde7fTmpAnwStunde8fTmpAnwStunde9fTmpAnwStunde10fTmpAnwStunde11fTmpAnwStunde12fTmpAnwStunde13fTmpAnwStunde14fTmpAnwStunde15fTmpAnwStunde16fTmpAnwStunde17fTmpAnwStunde18fTmpAnwStunde19fTmpAnwStunde20fTmpAnwStunde21fTmpAnwStunde22fTmpAnwStunde23fTmpAnwStunde24fTmpAnwStunde25fTmpAnwStunde26fTmpAnwStunde27fTmpAnwStunde28fTmpAnwStunde29fTmpAnwStunde30fTmpAnwStunde31fBezSummen
2Name,VornameA8,5;Q0,25E8,5    Q1,5;Q8,5Q8,5;Q1Q8,5;Q0,5Q5  E8,5;Q0,25E8,5;Q0,25A8,5A5Q5  E8,5;Q1E7,5;Q1           Summen: A 22     E 41,5     Q 41,25     V 159,5


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Die letzte Spalte mit den Summen (in der Tabelle keine wirklichen Summen, sondern Text) kopiere ich in die andereTabelle und will sie dort berechnen.
Einfacher wäre allerdings, ich könnte aus der Quelldatei direkt auslesen und diese Spalte auflösen.

Bild

Betrifft: Dann halt ohne
von: Michael
Geschrieben am: 26.04.2015 18:13:52
Hi Dori,
ich hab mal ein Makro geschrieben:


Option Explicit
Sub Werte_Trennen()
Dim i As Long, z As Long, von As Long, bis As Long, l As Long, posi As Long
Dim Zeile As String, Werte As String, buchstabe As String, Spalte As String
Dim buchUeberschrift As String, buchSpalte As String
'buchUeberschrift=Range("B12").Value
buchUeberschrift = "A Q P K U B E F V "
'buchSpalte=Range("B11").Value
buchSpalte = "ANAOAPAQARASATAUAV"
von = 2
bis = Range("AM" & Rows.Count).End(xlUp).Row
For z = von To bis
    Zeile = Range("AM" & z).Value
    l = Len(Zeile)
    Zeile = Mid(Zeile, 9, l - 8) & " "
    buchstabe = ""
    Werte = ""
    For i = 1 To l
      If Mid(Zeile, i, 1) >= "A" And Mid(Zeile, i, 1) <= "Z" Then
        buchstabe = Mid(Zeile, i, 1)
        Werte = ""
      End If
      If Mid(Zeile, i, 1) >= "0" And Mid(Zeile, i, 1) <= "9" Then
        posi = InStr(i, Zeile, " ")
        Werte = Werte & Mid(Zeile, i, posi - i)
        posi = InStr(buchUeberschrift, buchstabe)
        Spalte = Trim(Mid(buchSpalte, posi, 2))
        If InStr(Werte, ",") Then
            Range(Spalte & z).Value = Werte * 1#
          Else
            Range(Spalte & z).Value = Werte * 1
        End If
        i = i + Len(Werte)
        Werte = ""
      End If
    Next i
Next z
End Sub
Das Ding zerpflückt den Summmenstring, indem zuerst die ersten 8 Zeichen "Summen: " abgeschnitten werden und dann nach Buchstaben bzw. Zahlen gesucht wird.
Zur Positionierung dienen die zwei Strings, die mit "buch" anfangen, das sind die gefundenen Buchstaben und die damit korrespondierenden Excel-Spalten. Diese Lösung ist reichlich variabel: Du mußt nur die beiden Strings ändern, wenn Buchstaben hinzukommen bzw. andere Spalten verwendet werden sollen.
Das Makro sucht im einen String nach dem Buchstaben, merkt sich die Position und holt sich aus dem anderen die Buchstabenkombination der Spaltenüberschrift.
Falls Du *auch* Spalten mit nur einem Buchstaben verwenden willst, mußt Du eben statt z.B. "AM" eben eingeben "E " (mit Leerzeichen), das Leerzeichen aber dann entfernen, bevor Du das ans "Range" übergibst. Also gut, ich hab's gleich eingebaut: "trim" schneidet Leerzeichen ab.
Beispiel-Strings in B11 bzw. B12.
Datei anbei: https://www.herber.de/bbs/user/97311.xls
Happy Exceling,
Michael

Bild

Betrifft: AW: Dann halt ohne
von: Dori
Geschrieben am: 28.04.2015 11:24:27
Hallo Michael,
das ist es... wunderbar!
Habe meine Tabelle jetzt so umgebaut, dass das Ziel in anderen Spalten eingetragen werden soll, das habe ich in buchSpalte eingetragen.. (buchSpalte = "EFGHIJKLM")... da hängt er sich natürlich auf.. finde noch nicht, was ich da noch ändern muss...

Bild

Betrifft: AW: Dann halt ohne
von: Dori
Geschrieben am: 28.04.2015 11:26:59
wer lesen kann ist klar im Vorteil! das Leerzeichen war's... ;)
Vielen Dank für Deine Hilfe!! :) :)

Bild

Betrifft: Gerne
von: Michael
Geschrieben am: 28.04.2015 15:29:06
Hi Dori,
freut mich, wenn es funzt. "Wer lesen kann..." - sagt meine Steuerberaterin auch immer, hehe.
Eines noch: Das Makro hat bei meinen Tests funktioniert und bei Deinen offensichtlich auch.
Trotzdem ist mir nicht 100%ig wohl dabei, weil keine Fehler abgefangen werden. Man sollte vielleicht nach dem Schreiben des jeweiligen Zahlenwertes den Buchstaben auf leer ("") setzen und das dann abfragen, sobald man auf Zahlen losgeht - nur um sicherzustellen, daß auch ein Buchstabe gefunden wurde.
Ich mag's jetzt nicht einbauen, weil es sicher so läuft, so lange die Struktur der Daten sich nicht ändert, aber behalte es mal im Hinterkopf, ok?
Schöne Grüße,
Michael

Bild

Betrifft: AW: Gerne
von: Dori
Geschrieben am: 30.04.2015 09:26:04
Hallo Michael,
denke, so kann man es lassen, da sich die Struktur nicht ändern wird. Aber ich behalt's mal im Kopf und melde mich im Falle des Falles nochmal.
Nur blöd, dass die Threads hier nach einer Weile "abzulaufen" scheinen...
Meine Kollegen finden es übrigens im wahrsten Sinne "zabuerhaft", was unsre Excel nun kann... :D :D
Vielen Dank nochmal und liebe Grüße, Dori

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zahlen aus Zellen mit Buchstaben und Zahlen"