Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

nur Datum aus Zelle übernehmen

nur Datum aus Zelle übernehmen
05.04.2022 11:02:04
Gerd
Hallo Experten,
ich möchte aus einer Zelle, die sowohl Text als auch ein Datum enthält, nur das Datum übernehmen. Das Datum kann verschiedene Formate haben und steht auch nicht zwingend an der gleichen Position.
Zelleninhalt: "Collection: 202201 | weiterer Text" oder "Unit 01/2202, weiterer Text".
Ist das per Formel lösbar?
Beste Grüße
Gerd

18
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: nachgefragt ...
05.04.2022 11:13:50
neopa
Hallo Gerd,
... also normalerweise würde ich 202201 nicht als eine Datumsangabe betrachten. Welche "Formate" für eine zu suchende Datumsangabe können denn bei Dir noch alles möglich sein? Und vor allem können im Text vor oder nach einer solchen noch andere Zahlenangaben vorhanden sein?
Gruß Werner
.. , - ...
AW: nachgefragt ...
05.04.2022 11:26:37
Gerd
Hallo Werner,
ich weiß, dass 202201 kein in Excel übliches Datumsformat ist, aber in meinen Basisdaten ist es so angegeben. Damit muss ich arbeiten.
Es können nur die beiden angegebenen Formate vorkommen, also 202201 oder 01/2202. Und ja, es können auch noch andere Zahlen im Text vorkommen.
Was evtl. helfen könnte: Am Anfang steht immer entweder "Collection: 202201" oder "Unit 01/2202".
Die Ausgabe des Datums sollte nach Möglichkeit im Format 202201 erfolgen (ist aber nicht primär).
Beste Grüße
Gerd
Anzeige
AW: dann ...
05.04.2022 12:04:40
neopa
Hallo Andre,
... bezogen auf einen solchen Text in A1 z.B. so:
=WENN(ISTZAHL(SUCHEN("Collection";A1));TEIL(A1;SUCHEN("Collection: ";A1)+12;6);WENN(ISTZAHL(SUCHEN("Unit ";A1));TEXT((TEIL(A1;SUCHEN("Unit ";A1)+5;7)*1);"JJJJMM")))
Gruß Werner
.. , - ...
AW: dann ...
05.04.2022 12:28:07
Gerd
Hallo Werner,
vielen Dank, aber irgendwas haut noch nicht hin. ich bekomme entweder ein #Wert! oder ein FALSCH
Grüße
Gerd
AW: das FALSCH erklärt sich einfach ...
05.04.2022 12:41:58
neopa
Hallo Andre,
... dass in meiner Formel vor den letzten 2 Klammern noch ein "" fehlte also so: ......JMM";""))
Ein Ergebnis ein #Wert! kann nur in einer Zeile mit "Unit" kommen. Kannst Du einen solchen "anonymisierten" Text mal einstellen, wo diese Fehlermeldung kommt.
Gruß Werner
.. , - ...
Anzeige
AW: das FALSCH erklärt sich einfach ...
05.04.2022 12:59:51
Gerd
Hallo Werner,
die Fehlermeldung #WERT! kommt immer noch.
Die Zelleninhalte, inkl. exakter Positionen und Längen, sind entweder
Unitx xxxxx 02/2022, unitxxreport.org/b1234567
oder
Collec:20220187654|Collecx:2022021851S-N776
Grüße
Gerd
AW: die Textdaten sind aber jetzt anders owT
05.04.2022 13:26:10
neopa
Gruß Werner
.. , - ...
AW: aber das sind doch andere "Formate" ...
05.04.2022 13:22:21
neopa
Hallo Gerd,
.. als Du in Deiner Antwort um 11:26 auf meine Nachfrage angegeben hast. Dann wird eine Auswertung natürlich aufwendiger.
Gruß Werner
.. , - ...
Anzeige
AW: aber das sind doch andere "Formate" ...
05.04.2022 13:30:40
Gerd
Hallo Werner,
eigentlich ist es, wie ich es vorhin geschrieben habe:
Das Format 202201 kommt nach 7 Zeichen (Text). Das Datum danach sind die ersten 6 Ziffern
Das Format 01/2000 kommt nach 12 Zeichen (Text)
Grüße
Gerald
AW: nein, denn siehe Deinen vorherigen Beitrag ...
05.04.2022 13:40:23
neopa
Hallo Gerd,
... da hattest Du zusätzlich:

Unitx xxxxx 02/2022, unitxxreport.org/b1234567
oder
Collec:20220187654|Collecx:2022021851S-N776
Gruß Werner
.. , - ...
AW: nein, denn siehe Deinen vorherigen Beitrag ...
05.04.2022 13:51:43
Gerd
Hallo Werner,
sorry wenn das jetzt verwirrend war, der Fehler liegt bei mir.
Unitx xxxxx 02/2022, unitxxreport.org/b1234567
bzw.
Collec:2022012187654|Collecx:2022021851S-N776
sind die exakten Zellinhalte.
Nach 12 Zeichen (Text inkl. Leerzeichen) kommt das Format 01/2022 bzw. nach 7 Zeichen (Text inkl. Leerzeichen) kommt das Format 202201 (die ersten 6 Ziffern der 12-stelligen Zahl).
Grüße
Gerald
Anzeige
AW: nein, denn siehe Deinen vorherigen Beitrag ...
05.04.2022 14:00:04
Rudi
Hallo,

Nach 12 Zeichen (Text inkl. Leerzeichen) kommt das Format 01/2022 bzw. nach 7 Zeichen (Text inkl. Leerzeichen) kommt das Format 202201 (die ersten 6 Ziffern der 12-stelligen Zahl).
dann kannst du das doch einfach mit Wenn() und Teil() extrahieren.
Gruß
Rudi
AW: nein, denn siehe Deinen vorherigen Beitrag ...
05.04.2022 14:06:28
Gerd
Hallo Rudi,
genau das kriege ich als Excel-Laie nicht hin. Wie muss so eine Formel aussehen?
Und wie gesagt: die Ausgabe nach Möglichkeit in beiden Fällen im Format JJJJMM.
Grüße
Gerd
AW: nein, denn siehe Deinen vorherigen Beitrag ...
05.04.2022 14:44:51
Rudi

das kriege ich als Excel-Laie nicht hin
dann darfst du als Level nicht 'Excel gut' angeben.
Anzeige
AW: dann einfach ...
05.04.2022 14:22:29
neopa
Hallo Andre,
... so: =WENN(LINKS(A1;4)="Unit";TEXT(1*TEIL(A1;13;7);"JJJJMM");WENN(LINKS(A1;4)="Coll";TEIL(A1;18;6);""))
Gruß Werner
.. , - ...
AW: dann einfach ...
05.04.2022 14:48:39
Gerd
Super Werner, so haut es hin.
Vielen Dank
Gerd
AW: bitteschön owT
06.04.2022 11:15:43
neopa
Gruß Werner
.. , - ...

363 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige