Microsoft Excel

Herbers Excel/VBA-Archiv

doppelte Werte löschen, neue Zelle ausgeben (dyna

Betrifft: doppelte Werte löschen, neue Zelle ausgeben (dyna von: Sioo
Geschrieben am: 19.09.2014 15:47:06

Hallo, ich habe eine Tabelle mit 4 Spalten
In der ersten Spalte ist immer der jeweilige Company Code.

Ich bräuchte eine Formel die aus der Spalte den Company Code kopiert und die doppelten Werte entfernt und mir eine Zeile ausgibt mit allen Company Codes mit semikolon getrennt.

Haken:
Es kommen immer neue Zeilen dazu (die Formel sollte demnach dynamisch sein)

Beispieldatei anbei
https://www.herber.de/bbs/user/92729.xlsx

VG, Sioo

  

Betrifft: AW: doppelte Werte löschen, neue Zelle ausgeben (dyna von: Daniel
Geschrieben am: 19.09.2014 16:46:25

Hi

folgende Formel in E2 und bis ans Tabellenende kopieren:
=WENN(ISTFEHLER(FINDEN(A2;E3));";"&A2;"")&E3
das Gesamtergebnis steht in E2, die andernen Werte sind nur Zwischenergebnisse)

Das Semikolon am Anfang entfernst du mit =Teil(E2;2;32000)

Gruß Daniel


  

Betrifft: AW: doppelte Werte löschen, neue Zelle ausgeben (dyna von: Sioo
Geschrieben am: 19.09.2014 17:41:53

klappt bestens, danke


 

Beiträge aus den Excel-Beispielen zum Thema "doppelte Werte löschen, neue Zelle ausgeben (dyna "