VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Addition der absoluten Zahlen

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Addition der absoluten Zahlen

Problem

Wie kann ich die Summe der absoluten Zahlen einer Spalte ermitteln?

Lösung

Matrixformel: =SUMME(ABS(A2:A9))




StandardModule: basMain

Function Rank10Plus(rng As Range)
   Dim rngAct As Range
   Dim iValue As Integer
   For Each rngAct In rng.Cells
      If WorksheetFunction.Rank(rngAct.Value, rng) < 11 Then
         iValue = iValue + rngAct.Value
         iValue = iValue + rngAct.Offset(-1, 0).Value
         iValue = iValue + rngAct.Offset(1, 0).Value
      End If
   Next rngAct
   Rank10Plus = iValue
End Function

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion