VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Daten eines bestimmten Jahres filtern

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Daten eines bestimmten Jahres filtern

Problem

Wie kann ich die Vereinseintritte eines bestimmten Jahres über eine Funktion zählen lassen? Die Eintrittsdaten stehen in den Zellen A2:A1200.

Lösung

Die nachfolgende Matrixfunktion zählt die Eintritte des Jahres 98: {=SUMME((JAHR(A2:A1200)=1998)*1)}




StandardModule: Modul1

Sub Uebertragen()
   Dim lRow As Long
   With Worksheets("Daten")
      lRow = .Cells(Rows.Count, 1).End(xlUp).Row + 1
      Range("A5:E8").Copy .Cells(lRow, 1)
      .Range(.Cells(lRow, 6), .Cells(lRow + 3, 6)).Value = Date
   End With
   Application.CutCopyMode = False
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion