Microsoft Excel

Herbers Excel/VBA-Archiv

Matrix-Erstellung mit Excel - Erneut Hilfe!?

Betrifft: Matrix-Erstellung mit Excel - Erneut Hilfe!? von: Andreas
Geschrieben am: 29.06.2008 10:53:44

Hallo, ich hatte schon tolle Hilfe in diesem Forum bei der Erstellung von Matritzen in Excel.

Vielleicht könnt Ihr mir auch bei diesem Problem helfen:

Aus einer Datenbank sollen die Daten in eine Matrix eingetragen werden. Es geht um die Erfassung der Kontakte, die ein Akteur in einem Netzwerk hatte. Die Zeilen bilden die Häufigkeit eines Kontaktes mit einem Akteur ab. Die Diagonale bildet die gesamten ausgehenden Kontakte eines Akteurs ab (x).

Bsp: https://www.herber.de/bbs/user/53440.xls

Könnt Ihr mir da mit einer Formel weiterhelfen? Vielen Dank!

Grüße, Andreas

  

Betrifft: AW: Matrix-Erstellung mit Excel - Erneut Hilfe!? von: {Boris}
Geschrieben am: 29.06.2008 11:09:31

Hi Andreas,

E21:
=SUMMENPRODUKT(($D$5:$D$15=$D21)*($E$4:$I$4=E$20);$E$5:$I$15)

und in die anderen Zellen kopieren.

Grüße Boris