Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Zählenwenn in ZELLE
Mario
Hallo Zusammen,
bräuchte dringend heure Hilfe:
Habe in einer großen Tabelle kominationen aus Buchstaben und Zahlen stehen:
Spalte A
B1
S5
B5
B12
BB13
B2
möchte jetzt die Anzahl der Zellen mit nur einem B wissen (hier: 4) und die Anzahl BB (hier 1)
Kann mir jemand helfen?
Vielen Dank.
Grüße
Mario

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
also Beide zählen und subtrahieren ...
09.03.2011 18:18:36
Matthias
Hallo
Da gibts viele Varianten
Hier mal eine etwas Umständliche :o)
Tabelle1

 ABC
1Text2xB1xB
2B101
3S500
4B501
5B1201
6BB1311
7B201
8 14

Formeln der Tabelle
ZelleFormel
B2=WENN(LINKS(A2;2)="BB";1;0)
C2=WENN(LINKS(A2;1)="B";1;0)
B3=WENN(LINKS(A3;2)="BB";1;0)
C3=WENN(LINKS(A3;1)="B";1;0)
B4=WENN(LINKS(A4;2)="BB";1;0)
C4=WENN(LINKS(A4;1)="B";1;0)
B5=WENN(LINKS(A5;2)="BB";1;0)
C5=WENN(LINKS(A5;1)="B";1;0)
B6=WENN(LINKS(A6;2)="BB";1;0)
C6=WENN(LINKS(A6;1)="B";1;0)
B7=WENN(LINKS(A7;2)="BB";1;0)
C7=WENN(LINKS(A7;1)="B";1;0)
B8=SUMME(B2:B7)
C8=SUMME(C2:C7)-B8


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias
Anzeige
ist Blödsinn
09.03.2011 18:29:32
WF
Hi,
einfacher dann natürlich:
=ZÄHLENWENN(A1:A9;"B"&"*")
und
=ZÄHLENWENN(A1:A9;"BB"&"*")
aber was ist dann mit
BBB123
BBBBBBBBB22
WF
einer und zweier
09.03.2011 18:51:41
WF
=ZÄHLENWENN(A1:A9;"B"&"*")-ZÄHLENWENN(A1:A9;"BB"&"*")
und
=ZÄHLENWENN(A1:A9;"BB"&"*")-ZÄHLENWENN(A1:A9;"BBB"&"*")
kommen vor den B noch adere Zeichen, dann "*"&"B"&"*" etc.
WF

338 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige