Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Text und Zellbezug im Datumsformat in Zelle

Text und Zellbezug im Datumsformat in Zelle
31.07.2018 19:32:09
Andreas
Hallo Excelprofis,
In Zelle A1 steht ein Datum im Format JJJJ. Mit folgenter Funktion frage ich bestimmte Werte ab und möchte in der 2. Wenn-Abfrage als Ergebnis "Text2 2018 Text3" haben.
=WENN(UND(BH19"";BH19"";BH19>0);("Text2 "&$A$1&" Text3" );""))
Als Ergebnis wird mir aber "Text2 43101 Text3" ausgegeben.
Wie kann ich ereichen, dass der Bezug auf A1 als JJJJ ausgegeben wird.
Danke fürs lesen und die Hilfe,
mfg, Andreas

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Text und Zellbezug im Datumsformat in Zelle
31.07.2018 19:46:47
daniel
HI
Formeln verwenden immer den unformatierten Zellwert, und da ist ein Datum auch nur eine einfache Zahl.
In der Formel muss die Formatierung über die Funktion TEXT eingebracht werden:
aus ...&$A$1&... wird ...&Text(&$A$1&;"JJJJ")&...
in deinem Speziellen Fall könntest du auch die Funktion JAHR verwenden: ...&Jahr($A$1)&...
Gruß Daniel
AW: Text und Zellbezug im Datumsformat in Zelle
31.07.2018 19:54:45
Andreas
Hallo Daniel,
vielen Dank für die schnelle Hilfe, jetzt funktioniert es.
mfg, Andreas
Anzeige

336 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige