Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

Einzelne Wochentage aus Zellen mit Datum zählen | Herbers Excel-Forum


Betrifft: Einzelne Wochentage aus Zellen mit Datum zählen von: Karli
Geschrieben am: 14.12.2009 20:43:10

Hallo,

ich habe, um die Anzahl der einzelnen Wochentage in einer Spalte mit Datumangaben zu ermitteln, die Daten in einer anderen Spalte in Text umgewandelt, und dann Montage, Dienstage usw. gezählt.
Gibt es dafür auch einen direkten Weg die Summe bzw. Anzahl der einzelnen Wochentage in einer Zelle bzw. 7 Zellen auszuweisen?
Die Datumangaben sind benutzerdefiniert TTT, TT.MM.JJ in der Spalte A. Dazwischen befinden sich auch Leerzellen und Zellen mit Text.

Viele Grüße
Karli

  

Betrifft: AW: Einzelne Wochentage aus Zellen mit Datum zählen von: Josef Ehrensberger
Geschrieben am: 14.12.2009 21:03:03

Hallo Karli,

so?

Tabelle2

 ABCDEFG
1DatumWert   Summen 
2Di  01.12.2009475   Montag1534
3Mi 02.12.2009274   Dienstag1861
4Do 03.12.2009326   Mittwoch1338
5Fr  04.12.2009390   Donnerstag1493
6Sa 05.12.2009412   Freitag1196
7So 06.12.2009351   Samstag1372
8Mo07.12.2009289   Sonntag1482
9Di  08.12.2009413     
10Mi 09.12.2009196     
11Do 10.12.2009397     
12Fr  11.12.2009480     
13Sa 12.12.2009478     
14So 13.12.2009481     
15Mo14.12.2009445     
16Di  15.12.2009406     
17Mi 16.12.2009289     
18Do 17.12.2009364     
19Fr  18.12.2009104     
20Sa 19.12.2009377     
21So 20.12.2009382     
22Mo21.12.2009446     
23Di  22.12.2009264     
24Mi 23.12.2009227     
25Do 24.12.2009406     
26Fr  25.12.2009222     
27Sa 26.12.2009105     
28So 27.12.2009268     
29Mo28.12.2009354     
30Di  29.12.2009303     
31Mi 30.12.2009352     

Formeln der Tabelle
ZelleFormel
G2=SUMMENPRODUKT((WOCHENTAG($A$2:$A$31;2)=ZEILE(A1))*$B$2:$B$31)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Einzelne Wochentage aus Zellen mit Datum zählen von: Peter Feustel
Geschrieben am: 14.12.2009 21:06:28

Hallo Karli,

das könnte z. B. so laufen:
Option Explicit

Public Sub WochentageZaehlen()

Dim lZeile         As Long
Dim vTemp(1 To 7)  As Long
Dim iIndx          As Integer
Dim sText          As String

   With ThisWorkbook.Worksheets("Tabelle1") ' den Tabellenblattnamen ggf. anpassen!
      For lZeile = 1 To .Cells(Rows.Count, 1).End(xlUp).Row
         If Trim(.Range("A" & lZeile).Value) <> "" Then
            If IsDate(.Range("A" & lZeile).Value) Then
               vTemp(Weekday(CDate(.Range("A" & lZeile).Value))) = _
               vTemp(Weekday(CDate(.Range("A" & lZeile).Value))) + 1
            End If
         End If
      Next lZeile
   End With
  
   For iIndx = 1 To 7
      Select Case iIndx
         Case 1: sText = sText & "So " & vTemp(iIndx) & Chr(10)
         Case 2: sText = sText & "Mo " & vTemp(iIndx) & Chr(10)
         Case 3: sText = sText & "Di " & vTemp(iIndx) & Chr(10)
         Case 4: sText = sText & "Mi " & vTemp(iIndx) & Chr(10)
         Case 5: sText = sText & "Do " & vTemp(iIndx) & Chr(10)
         Case 6: sText = sText & "Fr " & vTemp(iIndx) & Chr(10)
         Case 7: sText = sText & "Sa " & vTemp(iIndx)
      End Select
   Next iIndx
   
   MsgBox sText
  
End Sub

Gruß Peter


  

Betrifft: AW: hier noch meine Test-Mappe von: Peter Feustel
Geschrieben am: 14.12.2009 21:36:46

Hallo Karli,

hier noch meine Test-Mappe https://www.herber.de/bbs/user/66594.xls

Gruß Peter


  

Betrifft: Wochentage zählen von: WF
Geschrieben am: 14.12.2009 21:10:00

Hi Karli,

folgende Arrayformel zählt Dir die Dienstage:
{=SUMME(WENN(ISTZAHL(A1:A99);WENN(WOCHENTAG(A1:A99;2)=2;1)))}

Aber Achtung: die nackten Zahlen 3 - 10 - 17 usw. werden auch als Dienstage gezählt.
(Kann man aber natürlich ebenso ausschließen wie Texte.)

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter (statt Enter allein); - das erzeugt sie.

Salut WF



http://www.excelformeln.de/
die ultimative Formelseite


  

Betrifft: AW: Einzelne Wochentage aus Zellen mit Datum zählen von: Karli
Geschrieben am: 14.12.2009 21:34:50

Hallo,
vielen Dank für die schnellen Antworten. Mit der Formel von WF habe ich meine Lösung gefunden. Meine alte Variante in zwei Schritten hat mich mächtig gewurmt.
Viele Grüße, einen schönen Abend und schöne Weihnachtstage.
Danke!
Karli


Beiträge aus den Excel-Beispielen zum Thema "Einzelne Wochentage aus Zellen mit Datum zählen"