Zählenwenns Platzhalter Datum/Zahl

Bild

Betrifft: Zählenwenns Platzhalter Datum/Zahl
von: Marcel
Geschrieben am: 03.11.2015 10:39:33

Guten Tag zusammen,
ich verzweifle gerade etwas an der Zählenwenns-Funktion:

=ZÄHLENWENNS(Bedingung,"1",EingabeAm,"1/##/2015")
Konkret möchte ich, dass alle Einträge aus dem Monat Januar, die die Bedingung = 1 erfüllen, gezählt werden. Allerdings werden meine Platzhalter nicht erkannt, egal welche Kombination ich aus den Zeichen #,?,*,~ verwende.
Das Datum im Namensfeld "EingabeAm" ist als amerikanisches Datum formatiert (Typ: *3/14/2001).
Bin für jede Antwort dankbar.
Gruß
Gruss

Bild

Betrifft: AW: Zählenwenns Platzhalter Datum/Zahl
von: SF
Geschrieben am: 03.11.2015 11:11:13
Hola,
nimm Summenprodukt:

=summenprodukt((A1:A10=1)*(Monat(B1:B10)=1)*(B1:B10<>""))
Zählt alle 1er aus A1 bis A10, wenn in B1 bis B10 der Monat Januar ist.
Gruß,
steve1da

Bild

Betrifft: AW: Zählenwenns Platzhalter Datum/Zahl
von: matthias
Geschrieben am: 03.11.2015 11:16:31
Hallo Marcel,
du willst also alle Daten kleiner dem 1.Feb., dann mach es so:

=ZÄHLENWENNS(A:A;1;B:B;"<" &DATUM(2015;2;1))
lg Matthias

Bild

Betrifft: AW: Zählenwenns Platzhalter Datum/Zahl
von: Marcel
Geschrieben am: 03.11.2015 11:25:27
Hallo Matthias,
habe ich mir zwar einfacher vorgestellt, funktioniert aber wunderbar.
Vielen Dank fuer deine Hilfe.

Bild

Betrifft: AW: Zählenwenns Platzhalter Datum/Zahl
von: matthias
Geschrieben am: 03.11.2015 11:47:08
Denk daran dass du auch noch eine Untergrenze festlegen musst (3. Bedingung, sonst zählst du für 2014 alles mit, bzw. für den Februar dann auch den Januar mit.

=ZÄHLENWENNS(A:A;1;B:B;"<" &DATUM(2015;2;1);B:B;">" &Datum(2014;12;31))


Bild

Betrifft: AW: Zählenwenns Platzhalter Datum/Zahl
von: SF
Geschrieben am: 03.11.2015 11:51:34
Hola,
einfacher siehe oben. Ansonsten ermittelst du mit =monat(B1) die Monate der einzelnen Daten und lässt Zählenwenns darauf ermitteln.
Gruß,
steve1da

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenns Platzhalter Datum/Zahl"