VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Werte eines bestimmten Wochentages und eines Zeitbereiches addieren

Gruppe

Matrix

Bereich

WOCHENTAG

Thema

Werte eines bestimmten Wochentages und eines Zeitbereiches addieren

Problem

Wie kann ich aus einer Tabelle alle Werte eines bestimmten Wochentages und einem bestimmten Zeitbereich addieren?

Lösung

Folgende Matrixformel: =SUMME((A1:A13>9/24)*(A1:A13<=18/24)*(WOCHENTAG(B1:B13,2)<6)*(C1:C13))




StandardModule: Modul1

Sub Markierne()
   Dim rng As Range
   Set rng = Range("A1").CurrentRegion
   Dim iRow As Integer, iColC As Integer, iCol As Integer
   
   
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und WOCHENTAG