Thema

Anzahl der Wochentage in einem vorgegebenen Zeitraum ermitteln

Gruppe

WOCHENTAG

Problem

Wie kann ich das Vorkommen eines bestimmten Wochentages in einem vorgegebenen Zeitraum ermitteln?

Lösung
Matrixformel: =SUMME(WENN(WOCHENTAG(B2-1+ZEILE(INDIREKT("1:"&KÜRZEN(B3-B2)+1)))=B1;1;0))



StandardModule: basMain

Function ArrayCount( _
   ParamArray arr() As Variant) As Integer
   ArrayCount = UBound(arr) + 1
End Function

Sub Aufruf()
   MsgBox ArrayCount(5, 7, 9, 11, 13)
End Sub

    

Beiträge aus dem Excel-Forum zu den Themen Matrix und WOCHENTAG