VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Aus Liste Anzahl der Januartage eines bestimmten Jahres listen

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Aus Liste Anzahl der Januartage eines bestimmten Jahres listen

Problem

Aus einer Datenreihe einer Tabelle soll die Anzahl der Januartage eines bestimmten Jahres ermittelt werden.

Lösung

Matrixformel: =SUMME((MONAT(Tabelle1!$A1:A40)=1)*(JAHR(Tabelle1!A1:A40)=2002)*1)




StandardModule: Modul1

Sub FileSelection()
   Dim var As Variant
   Dim iCounter As Integer
   var = Application.GetOpenFilename( _
      FileFilter:="Excel-Dateien (*.xls), *.xls", _
      MultiSelect:=True)
   On Error GoTo ERRORHANDLER
   For iCounter = 1 To UBound(var)
      MsgBox iCounter & ". Datei von " & UBound(var) & ": " & var(iCounter)
   Next iCounter
   Exit Sub
ERRORHANDLER:
   Beep
   MsgBox "Abbruch!"
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion