VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Addition von Werten links und rechts eines Doppelpunktes

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Addition von Werten links und rechts eines Doppelpunktes

Problem

Die Werte links und rechts eines Doppelpunktes (z.B. Spielergebnisse) sollen addiert werden.

Lösung

Folgende Matrixformel: =SUMME(WERT(LINKS(A1:A6;FINDEN(":";A1:A6)-1)))&":"&SUMME(WERT(RECHTS(A1:A6;LÄNGE(A1:A6)-FINDEN(":";A1:A6))))




StandardModule: basMain

Function Rank10Plus(rng As Range)
   Dim rngAct As Range
   Dim iValue As Integer
   For Each rngAct In rng.Cells
      If WorksheetFunction.Rank(rngAct.Value, rng) < 11 Then
         iValue = iValue + rngAct.Value
         iValue = iValue + rngAct.Offset(-1, 0).Value
         iValue = iValue + rngAct.Offset(1, 0).Value
      End If
   Next rngAct
   Rank10Plus = iValue
End Function

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion