Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Anzahl in einer Zeile ziehen mit Bedingungen

Anzahl in einer Zeile ziehen mit Bedingungen
05.12.2008 09:16:59
Eva
Hallo,
ich möchte innerhalb einer Zeile folgende Rechenoperation durchführen:
Wenn die Zahl kleiner als 15 ist, sollen die Anzahl der Werte in einer Zeile genommen und addiert werden. Wenn die Werte die größer als 15 sind, sollen sie durch 15 geteilt werden und ebenfalls dann die Anzahl addiert werden.
Also zum Beispiel folgende Reihe:
1; 3; 9; 26; 23; 8; 17; 8
Ich hätte gerne die Anzahl: 1+1+1+1,73+1,53+1+1,13+1= 9,39.
Geht das?
Danke im Voraus.
Mit freundlichen Grüßen
Eva

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Anzahl in einer Zeile ziehen mit Bedingungen
05.12.2008 09:24:56
Beate
Hallo Eva,
 AB
119,40
23 
39 
426 
523 
68 
717 
88 

Formeln der Tabelle
ZelleFormel
B1=ZÄHLENWENN(A1:A8;"<"&15)+SUMMEWENN(A1:A8;">=15";A1:A8)/15

Gruß,
Beate
Anzeige
AW: Anzahl in einer Zeile ziehen mit Bedingungen
05.12.2008 10:08:00
Eva
Hallo Beate,
das ist ja fantastisch!
Geht auch folgendes?:
Anzahl nehmen wenn unter 15; wenn über 15 2x die Anzahl nehmen; wenn über 30 3x die Anzahl nehmen? Bei unserem Beispiel würde dann genau 10 rauskommen.
Eva
AW: Anzahl in einer Zeile ziehen mit Bedingungen
05.12.2008 10:32:00
Beate
Hallo Eva,
ich bin der Meinung, da kommt 11 raus:
 AB
1111,00
23 
39 
426 
523 
68 
717 
88 

Formeln der Tabelle
ZelleFormel
B1=ANZAHL(A1:A8)*3-ZÄHLENWENN(A1:A8;"<"&30)-ZÄHLENWENN(A1:A8;"<"&15)

Unklar ist: Du schreibst: "wenn unter 15; wenn über 15" - Was ist genau mit 15? Gleiches gilt für 30.
Kannst ja auch mit <= und >= arbeiten.
Gruß,
Beate
Anzeige
Vielen Dank!
05.12.2008 11:42:00
Eva
Danke. Du bist echt gut drauf. Dein Hinweis war natürlich komplett richtig und ich habe ihn umgesetzt.

321 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige