Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Anzahl mit Bedingung
Anton
hallo.
ich möchte gerne eine anzahl berechnen lassen, die aber an eine bedingung geknüpft ist.
ich habe einen datenbereich von B243 bis J313 und nun soll mir für jede spalte die anzahl ausgewiesen werden (nicht in jeder zeile sind angaben) - aber mit der bedingung, dass die zeile in jeder spalte angaben haben muss.
wie gehe ich da am besten vor?

16
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Anzahl mit Bedingung
14.07.2009 15:29:09
Matthias5
Hi Anton,
wenn die Zeilen, die gezählt werden sollen, in jeder Spalte einen Eintrag haben müssen, dann ist die Anzahl doch immer gleich - oder nicht?
Gruß
Matthias
AW: Anzahl mit Bedingung
14.07.2009 15:40:30
Anton
nee (kann kein bsp. hochladen), wenn:
a1=1, B1=1, C1=0
a2=1, B2=1, C2=1
a3=1, b3=0, C3=1
dann wäre die summe spalte a = 1 (und nicht 3), da nur in zeile 2 in allen spalten auch angaben sind
so ist es gemeint (kurzform)
0 (Null) ist auch eine Angabe ...
14.07.2009 15:59:05
Matthias
Hallo
... oder meinst Du leer. Das ist ein Unteschied
hier mal wie ich es jetzt interpretieren
Userbild
Gruß Matthias
Anzeige
AW: Anzahl mit Bedingung
14.07.2009 16:00:24
Matthias5
Hallo Anton,
=SUMME(1*(MMULT(1*(B243:J313"");ZEILE(1:9)^0)=9))
Siehe auch hier: http://www.excelformeln.de/formeln.html?welcher=45
Es verwirrt mich aber immer noch: Du wolltest das ja pro Spalte haben und diese Summe ist natürlich in jeder Spalte gleich. Wahrscheinlich habe ich es immer noch nicht richtig verstanden.
Gruß,
Matthias
AW: Anzahl mit Bedingung
14.07.2009 16:11:57
Anton
doch, ich glaube du hast das richtig verstanden (ich mich nur blöd ausgedrückt).
scheint auch zu funktionieren. nun kann es aber auch noch sein, dass statt der 0 eine zelel leer ist. d.h. das müsste auch noch berücksichtigt werden. ansonsten ist es immer 0 im ergebnis. danke für die hilfe.
Anzeige
AW: Anzahl mit Bedingung
14.07.2009 16:21:31
Matthias5
Dann so:
=SUMME(1*(MMULT(1*((B243:J313"")-(B243:J313=0));ZEILE(1:9)^0)=9))
Gruß,
Matthias
AW: Anzahl mit Bedingung
14.07.2009 16:25:20
Anton
wird mir leider dennoch null ausgewiesen
AW: Anzahl mit Bedingung
14.07.2009 16:30:48
Matthias5
Die Formel funktioniert so. Sie zählt alle Zeilen im Bereich, die nicht entweder eine Leerzelle oder eine Null enthalten! Sind die Nullen in deiner Datei echte Zahlen oder liegen sie intern als Text vor? Wie werden sie generiert?
AW: Anzahl mit Bedingung
14.07.2009 16:32:56
Anton
war eine formatierung der zelle. umgestellt und nun geht es wunderbar. danke
Na wunderbar! oT
14.07.2009 16:34:35
Matthias5
AW: Anzahl mit Bedingung
14.07.2009 16:33:47
Matthias5
Bin jetzt erst mal weg. Sollten die Nullen als Text vorliegen, versuche mal diese Erweiterung:
=SUMME(1*(MMULT(1*((B243:J313"")-(B243:J313=0)-(B243:J313="0"));ZEILE(1:9)^0)=9))
Anzeige
ich versteh Deine Frage nicht ganz
14.07.2009 15:36:01
Matthias
Hallo
Kannst Du ein Beispiel zeigen was Du wo und warum erwartest
Dein Beispiel ginge mit Anzahl() oder Anzahl2()
Das ergibt aber dann immer 9, wenn alle gefüllt sind.
Evtl willst Du ja aber auch die Summe bilden aus allen 9 Spalten der jeweiligen Zeile.
aber nur wenn alle Zellen gefüllt sind.
Also ich komm mit Deiner Frage noch nicht ganz klar.
Kannst Du etwas genauer formulieren?

Gruß Matthias
AW: ich versteh Deine Frage nicht ganz
14.07.2009 15:50:50
Anton
siehe erläuterung weiter oben
AW: Anzahl mit Bedingung
14.07.2009 15:56:23
Mücke
Hallo Anton,
meinst du es so?
Tabelle2

 ABC
1110
2111
3101
4100
5100

Formeln der Tabelle
ZelleFormel
A4=WENN(ZEILE()-1=ZÄHLENWENN(A1:A3;"<>0"); 1;0)
B4=WENN(ZEILE()-1=ZÄHLENWENN(B1:B3;"<>0"); 1;0)
C4=WENN(ZEILE()-1=ZÄHLENWENN(C1:C3;"<>0"); 1;0)
A5=WENN(ANZAHL2(A1:A3)=ZÄHLENWENN(A1:A3;"<>0"); 1;0)
B5=WENN(ANZAHL2(B1:B3)=ZÄHLENWENN(B1:B3;"<>0"); 1;0)
C5=WENN(ANZAHL2(C1:C3)=ZÄHLENWENN(C1:C3;"<>0"); 1;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Dirk
Anzeige
AW: Anzahl mit Bedingung
14.07.2009 16:06:03
Ptonka
Hallo Anton,
nutze eine Hilsspalte neben Deinen Spalten und frage hier nach den leeren Inhalten ab.
Beispiel:
Dein Beispiel:
A1 = 1, B1 = leer, C1 = 1
A2 = 1, B2 = 1 , C2 = 1
A3 = 1, B3 = 1 , C3 = leer
in D1 folgende Formel: =WENN(ODER(ISTLEER(A1)=WAHR;ISTLEER(B1)=WAHR;ISTLEER(C1)=WAHR);WAHR;FALSCH)
Anschliessend in einer belibiebigen Zelle folgende Formel: =SUMMEWENN(D1:D3;FALSCH;A1:A3)
Gruß,
Ptonka
AW: Anzahl mit Bedingung
14.07.2009 16:12:45
Anton
auch möglich, aber der oben genannte tipp ist super. da muss nur noch eine weitere bedingung mit dem leer rein. danke dennoch!

313 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige