Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zeilenanzahlen/Inhalte von mehreren Blöcken zählen

Zeilenanzahlen/Inhalte von mehreren Blöcken zählen
23.08.2013 15:29:08
mehreren
Ich möchte so eine Art Stundenplan verfassen.
Dabei sollen quasi Blöcke gezählt werden.
Folgende Tabelle ist die bisherige Ausgangstabelle: A B C D 1 0.25 EINS ZWEI 2 0.25 EINS 3 0.25 4 0.25 5 0.25 DREI DREI 6 0.25 EINS 7 0.25 8 0.25 EINS 9 0.25 10 0.25 EINS 11 0.25 ZWEI 12 0.25 ZWEI 13 0.25 14 0.25 Zeile B sind hier mal Viertelstunden, EINS, ZWEI, DREI sind Blöcke, deren Gesamtdauer ich zählen möchte.
Also ich will bspw. herausfinden, wie viele Stunden Block EINS gefüllt hat.
Meine Idee war bisher:
Summiere B für gefundene erste EINS inkl. leerer Zeilen bis gefundene nächste nicht leere Zeile (DREI) minus 1, addiert um nächsten summierten Block EINS bis vor nächsten startenden Block, - für den gesamten Bereich C1:D14. (Eine Einschränkung auf eine Spalte (C1:C14) wäre denkbar)
Das ganze natürlich ebenso für Blocktyp ZWEI, etc.
An der Umsetzung scheitere ich aktuell.
Für hilfreiche Vorschläge bin ich sehr dankbar.

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zeilenanzahlen/Inhalte von mehreren Blöcken zählen
23.08.2013 19:34:15
mehreren
HAllo
Wenn du die Leerzellen mit den Werten "von oben füllst" wirds ganz einfach:
Tabelle1

 ABCDEFGH
10,25EINSZWEI  BC 
20,25EINSEINS EINS2,251,75 
30,25EINSEINS ZWEI11 
40,25EINSEINS DREI0,250,75 
50,25DREIDREI     
60,25EINSDREI     
70,25EINSDREI     
80,25EINSEINS     
90,25EINSEINS     
100,25EINSEINS     
110,25ZWEIEINS     
120,25ZWEIZWEI     
130,25ZWEIZWEI     
140,25ZWEIZWEI     
15        
16        
17        
18        
19        

Formeln der Tabelle
ZelleFormel
F2=SUMMEWENN($B$1:$B$14;$E2;$A$1:$A$14)
G2=SUMMEWENN($C$1:$C$14;$E2;$A$1:$A$14)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
ransi

Anzeige
AW: Zeilenanzahlen/Inhalte von mehreren Blöcken zählen
25.08.2013 22:38:50
mehreren
Danke für die Antwort, ransi!
Allerdings geht es in diesem Fall leider nicht "ganz einfach", die Felder dazwischen müssen leer bleiben, aber dennoch als zum vorherigen Eintrag zugehörig mitgezählt werden.

323 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige