Summe aus Zahlen im Text

Bild

Betrifft: Summe aus Zahlen im Text
von: Nicolai
Geschrieben am: 28.08.2015 15:14:09

Hallo zusammen,
ich komme bei meiner Formel nicht weiter und bräuchte eure Hilfe.
Ich habe folgende Formel:
=SUMMENPRODUKT((A15:H15>I5)*(A15:H15 In Zeile 15 steht ein fortlaufendes Datum.
In I5 steht ein Datum (von)
In J5 steht ein Datum (bis)
In der Zeile 16 steht öfters mal folgender Eintrag "0,50 Stunde(n) Kal-Mehrarbeit" Es kann aber auch mal "test123 | 0,75 Stunde(n) Kal-Mehrarbeit" stehe.
Aktuell zählt er, wie oft in den Bereich x(Datum von bis) "Kal-M" vorkommt.
Nun will ich allerdings das er immer wenn "Kal-M" steht, das er die zahl die vorne dran steht nimmt und zusammen addiert.
Für eine Zelle habe ich es Geschäft das er mir die Zahl heraus liest:
=TEIL(A1;FINDEN("Kal-M";A1)-14;4)
Ich bekomme es nicht hin, dieses beiden Formel zu verbinden.
Kann mir jemand von euch auf die Sprünge helfen.
Freundliche Grüße,
Nicolai

Bild

Betrifft: AW: Summe aus Zahlen im Text
von: Mike
Geschrieben am: 28.08.2015 15:25:34
Hallo Nicolai,
leider fehlt in deiner ersten Formel das Ende, so dass es weder einen Bezug auf J5 noch Zeile 16 gibt.
Viele Grüße
Mike

Bild

Betrifft: AW: Summe aus Zahlen im Text
von: Nicolai
Geschrieben am: 28.08.2015 15:39:30


=SUMMENPRODUKT((A15:H15>I5)*(A15:H15"<"J5)*ISTZAHL(SUCHEN($I$4;A16:H16)))

Denkt euch die Anführungszeichen weg, ohne wollte er es mir nicht erkennen.
Hier die korrekte Formel. Irgendwie hat er es nicht abgesendet.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summe aus Zahlen im Text"