Microsoft Excel

Herbers Excel/VBA-Archiv

Summe von / bis in Abhängigkeit von 2 Kriterien | Herbers Excel-Forum


Betrifft: Summe von / bis in Abhängigkeit von 2 Kriterien von: Nils Louwien
Geschrieben am: 25.07.2012 12:55:50

Moin Moin,

ich habe da ein Problem welches eventuell ganz einfach zu lösen ist. Leider komme ich nicht drauf.

Folgende Datei habe ich: https://www.herber.de/bbs/user/81155.xls

In Spalte D möchte ich eine Formel hinterlegen, die Automatische eine Summe über die Menge aus Spalten D bis AC bildet wobei in Spalte B die erste Zelle ist die aufsummiert werden soll C die Letzte.

Also soll anhand des von bis Datums eine Summe der jeweiligen Zeile gebildet werden ohne VBA verwenden zu müssen.

Für Eure Hilfe wäre ich sher dankbar!

Vielen Dank!

Gruß

Nils

  

Betrifft: AW: Summe von / bis in Abhängigkeit von 2 Kriterien von: Peter Müller
Geschrieben am: 25.07.2012 13:29:22

Hallo,

in D2:

=SUMME(BEREICH.VERSCHIEBEN(E2;0;VERGLEICH($B2;$F$1:$AC$1;0);1;VERGLEICH($C2;$F$1:$AC$1;0))) 
und runter kopieren.

Gruß,
Peter


  

Betrifft: AW: Summe von / bis in Abhängigkeit von 2 Kriterien von: Nils Louwien
Geschrieben am: 25.07.2012 13:52:46

Moin Moin,

vielen Dank für die schnelle Antwort! Funktioniert super!

Lieben Gruß


  

Betrifft: AW: Summe von / bis in Abhängigkeit von 2 Kriterien von: Uwe (:o)
Geschrieben am: 25.07.2012 13:38:32

Hallo Nils,
teste mal in D2 und runterkopieren:

=SUMMENPRODUKT(($F$1:$AC$1>=B2)*($F$1:$AC$1<=C2)*($F2:$AC2))

Gruß
Uwe
(:o)


  

Betrifft: AW: Summe von / bis in Abhängigkeit von 2 Kriterien von: Nils Louwien
Geschrieben am: 25.07.2012 13:52:24

Moin Moin,

vielen Dank für die schnelle Antwort! Funktioniert super!

Lieben Gruß


Beiträge aus den Excel-Beispielen zum Thema "Summe von / bis in Abhängigkeit von 2 Kriterien"