Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENN mit Datum


Betrifft: SUMMEWENN mit Datum von: Henner
Geschrieben am: 18.01.2018 09:30:16

Hallo Zusammen,

ich habe ein paar Probleme mit einer Formel, wäre schön wenn ihr mir auf die Sprünge helfen könntet .. :-)!

Spalte B2 = C2 (Bedingt formatiert auf MMMM - Nur der Monat wird angezeigt)
Spalte C2 = Bedarfsdatum (z.B. 10.01.2017)
Spalte D2 = Preis ..( z.B. 500 €)

Ich möchte mit einer Formel für jeden einzelnen Monat den Gesamtpreis ermitteln.

Bis jetzt getestet habe ich - SUMMEWENN(C:C;“Januar“;D:D) .. aber da kommt leider nur 0 raus.
Habt ihr eine Idee? Danke!

  

Betrifft: AW: SUMMEWENN mit Datum von: SF
Geschrieben am: 18.01.2018 09:38:12

Hola,

=SUMMENPRODUKT((MONAT(C2:C100)=1)*(D2:D100))

Gruß,
steve1da


  

Betrifft: AW: SUMMEWENN mit Datum von: Mirko
Geschrieben am: 18.01.2018 09:48:12

Hallo

bin zwar kein so ein Profi wie die anderen hier, aber bin der Meinung das wenn du "Januar" schreibst dann sucht Excel auch nach einem Januar, du hast zwar Januar in C2 stehen aber das ist ein Datum und kein Text. Wenn du es so schreibst =SUMMEWENN(C:C;DATUM(2017;1;10);D:D) dann geht es, vielleicht konnte ich dir bisschen helfen.

Gruß Mirko


  

Betrifft: AW: SUMMEWENN mit Datum von: Henner
Geschrieben am: 18.01.2018 09:59:44

Hi,

hier liegt wahrscheinlich auch mein Fehler! Ich habe in Spalte B2 ja mehr oder weniger nur auf C2 (Bedarfsdatum) verwiesen und die Formatierung auf "MMMM - Januar" umgeändert. Gibt es eine Möglichkeit per FORMEL, um aus dem Datum ein TEXT zu machen, damit meine Formel funktioniert?


  

Betrifft: AW: SUMMEWENN mit Datum von: SF
Geschrieben am: 18.01.2018 10:05:50

Hola,

ja. Steht übrigens schon im Thread.

Gruß,
steve1da


  

Betrifft: null und leer ist auch Januar von: WF
Geschrieben am: 18.01.2018 10:08:31

Hi,

und sonstige (kleine) Zahlen sollte man auch ausschließen:
=SUMMENPRODUKT((MONAT(C2:C100)=1)*(C2:C100>10000)*(D2:D100))

WF


  

Betrifft: Hast Recht. owT von: SF
Geschrieben am: 18.01.2018 10:12:00




  

Betrifft: Hast Recht. owT von: SF
Geschrieben am: 18.01.2018 10:12:01




Beiträge aus dem Excel-Forum zum Thema "SUMMEWENN mit Datum"