Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
560to564
560to564
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Summewenn Artikel Datum
05.02.2005 14:49:33
Alfons
Hallo,
es gibt viele die mir helfen können, davon bin ich überzeugt. Ich habe folgendes Problemchen. Ich habe einen Tabellen mit Daten und eine wo ich die Berechnungen durchführen will. Nun möchte ich folgende Matrix aufbauen und eben die entsprechenden Summen ermitteln.
In dem Tabellenblatt "Daten" habe ich folgende Spalten
Spalte D Material, Spalte J MMJJ (12.03,01.04 usw.),
In der Spalte E befinden sich die jeweiligen Liefermengen, wobei natürlich jeder Artikel pro Monat mehrfach vorkommen kann.
Wie kriege ich soetwas mit der "Summewenn" hin? Mir gelingt es bis eben überhaupt nicht.
12.03 01.04 02.04 03.04 04.04
104L2505
104L1504
104L1806
104L2105
104L1605
104L2536
104L2804
104L1503
104L2107
104L2607
Gruss
Alfons

16
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summewenn Artikel Datum
r.sch.
Hi Alfons,
ohne lange nachzudenken, da wirst du mit Sicherheit unter www.excelformeln.de etwas passendes finden. Viel Glück.
Gruß aus 'm Vorharz
Reinhard
AW: Summewenn Artikel Datum
05.02.2005 17:51:42
Alfons
Hi,
tja aber ich bin leider nicht in der Lage die Formel zu einem anderen Ergebnis als 0 zu führen.
Gruss
Alfons
AW: Summewenn Artikel Datum
Jens_Pu
Hallo Alfons,
kannst Du mal eine Mustermappe hochladen?
Gruß Jens
AW: Summewenn Artikel Datum
Hübi
Hi Alfons,
meinst du es so
Tabelle1
 DEFGHIJKLM
1MaterialMengen    Datum Gesucht 
2104L2505 2    12.03 Material104L2105
3104L1504 5    01.04 Datum03.04
4104L1806 2    02.04 Summe10
5104L2105 6    03.04   
6104L1605 2    01.04   
7104L2536 5    02.04   
8104L2804 4    03.04   
9104L1503 3    02.04   
10104L2107 6    01.04   
11104L2105 4    03.04   
Formeln der Tabelle
M4 : {=SUMMENPRODUKT((D2:D15=M2)*(MONAT(J2:J15)=MONAT(M3))*(JAHR(J2:J15)=JAHR(M3))*(E2:E15))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Hübi
Anzeige
AW: Summewenn Artikel Datum
05.02.2005 19:46:04
Alfons
Hallo Hübi,
nein ich brauche die Mengen nach Monat und jeweils nach Artikelnummer.
Wie unter Summe_Gesamt dargestellt, aber das scheint nicht so einfach zu sein.
Gruss
Alfons
AW: Summewenn Artikel Datum
Alfons
Hi Hübi,
ich lade nochmals die Mappe hoch welche ich nun mit Deiner Formel eingegeben habe, allerdings ermittle ich nun einen Wert von 841, wo eigentlich 40 stehen müsste.
https://www.herber.de/bbs/user/17528.xls
Gruss
Alfons
AW: Summewenn Artikel Datum
Alfons
Hi Hübi,
ich lade nochmals die Mappe hoch welche ich nun mit Deiner Formel eingegeben habe, allerdings ermittle ich nun einen Wert von 841, wo eigentlich 40 stehen müsste.
https://www.herber.de/bbs/user/17528.xls
Gruss
Alfons
Anzeige
AW: Summewenn Artikel Datum
Alfons
Hi Hübi,
ich lade nochmals die Mappe hoch welche ich nun mit Deiner Formel eingegeben habe, allerdings ermittle ich nun einen Wert von 841, wo eigentlich 40 stehen müsste.
https://www.herber.de/bbs/user/17528.xls
Gruss
Alfons
AW: Summewenn Artikel Datum
05.02.2005 21:54:02
Alfons
Hi Hübi,
in dieser Mappe wird jeweils ERR:504 gemeldet, woran liegt das denn?
Gruss
Alfons
AW: Summewenn Artikel Datum
Hübi
Hi Alfons,
da ich mit der Fehlermeldung nichts anfangen kann, hier ein Abbild der Lösung in deiner Datei
Summe_Gesamt
 DEFGHIJK
2 12.0301.0402.0403.0404.0405.0406.04
3104L2505400080016080
4104L15041601602403208001520240
5104L180614400018258410803600
6104L210501040013
7104L16050640800800137016800
8104L253600210000
9104L28040000210150240
10104L150300008004
11104L21070000000
12104L26070000000
Formeln der Tabelle
E3 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D3)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F3 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D3)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G3 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D3)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H3 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D3)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I3 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D3)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J3 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D3)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K3 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D3)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
E4 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D4)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F4 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D4)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G4 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D4)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H4 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D4)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I4 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D4)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J4 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D4)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K4 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D4)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
E5 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D5)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F5 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D5)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G5 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D5)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H5 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D5)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I5 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D5)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J5 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D5)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K5 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D5)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
E6 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D6)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F6 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D6)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G6 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D6)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H6 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D6)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I6 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D6)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J6 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D6)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K6 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D6)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
E7 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D7)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F7 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D7)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G7 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D7)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H7 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D7)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I7 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D7)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J7 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D7)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K7 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D7)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
E8 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D8)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F8 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D8)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G8 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D8)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H8 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D8)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I8 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D8)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J8 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D8)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K8 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D8)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
E9 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D9)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F9 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D9)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G9 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D9)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H9 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D9)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I9 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D9)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J9 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D9)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K9 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D9)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
E10 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D10)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F10 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D10)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G10 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D10)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H10 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D10)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I10 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D10)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J10 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D10)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K10 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D10)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
E11 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D11)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F11 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D11)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G11 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D11)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H11 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D11)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I11 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D11)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J11 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D11)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K11 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D11)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
E12 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D12)*(MONAT(Daten!$J$2:$J$1000)=MONAT(E$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(E$2))*(Daten!$E$2:$E$1000))
F12 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D12)*(MONAT(Daten!$J$2:$J$1000)=MONAT(F$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(F$2))*(Daten!$E$2:$E$1000))
G12 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D12)*(MONAT(Daten!$J$2:$J$1000)=MONAT(G$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(G$2))*(Daten!$E$2:$E$1000))
H12 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D12)*(MONAT(Daten!$J$2:$J$1000)=MONAT(H$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(H$2))*(Daten!$E$2:$E$1000))
I12 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D12)*(MONAT(Daten!$J$2:$J$1000)=MONAT(I$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(I$2))*(Daten!$E$2:$E$1000))
J12 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D12)*(MONAT(Daten!$J$2:$J$1000)=MONAT(J$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(J$2))*(Daten!$E$2:$E$1000))
K12 : =SUMMENPRODUKT((Daten!$D$2:$D$1000=$D12)*(MONAT(Daten!$J$2:$J$1000)=MONAT(K$2))*(JAHR(Daten!$J$2:$J$1000)=JAHR(K$2))*(Daten!$E$2:$E$1000))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Hübi
Anzeige
AW: Summewenn Artikel Datum
05.02.2005 22:11:11
Alfons
Hi Hübi,
ich glaube das liegt daran das ich mit OpenOffice arbeite, hier scheint es wohl Probleme zu geben.
Gruss
Alfons
AW: Summewenn Artikel Datum
Hübi
Hi Alfons,
OpenOffice.org 1.1.1 kennt SUMMENPRODUKT() auch. Kopiere von der Seite doch einfach mal die Formel in E3 und ziehe über die restlichen Zellen.
Kann es z.Z. leider nicht testen, da ich gerade am Update von Linux bin.
Melde mich noch einmal.
Gruß Hübi
AW: Summewenn Artikel Datum
05.02.2005 22:36:24
Alfons
Stimmt schon Ooo 1.1. kennt die Formel, meldet mir aber einen Parameterfehler. Was ich weiß ist das anstatt des "!" ein "." jeweils hinter verweisende Tabellen kommt. Den Rest bin ich noch am prüfen, warum das ganze nicht will.
Gruss
Alfons
Anzeige
AW: Summewenn Artikel Datum
Hübi
Hi Alfons,
habe es gerade mit OOo ausprobiert und komme zum gleichen Ergebnis wie du.
Weiß allerdings keine anderes Lösung, als dass du mit massig Hilfsspalten deine Daten so aufbereitest, dass Summewenn() anwendbar wird.
Gruß Hübi

320 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige