Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
528to532
528to532
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

SUMMEWENN mit Datumsbeschränkung

SUMMEWENN mit Datumsbeschränkung
07.12.2004 08:00:41
Clemens
Hallo Excels,
ich suche schon seit einiger Zeit im Internet nach einer Möglichkeit, Beträge anhand eines Datumsbereichs zu summieren, also zB. die Tabelle:

















A B
05.11.200430,-
01.12.200450,-
13.12.200460,-
01.01.200520,-

Die Werte in Spalte B sollen nur summiert werden, wenn das Jahr des Datums 2005 und der Monat 11 ist. Funktioniert das mit SUMMEWENN bzw. wie könnte man das noch lösen? Danke für Eure Hilfe,
lg Clemens

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: SUMMEWENN mit Datumsbeschränkung
07.12.2004 08:08:36
Heinz
Hallo Clemens,
das kann mit einer Arrayformel (Strg+Alt+Enter) realisiert werden:
{=SUMME((MONAT(A2:A13)=D2)*(JAHR(A2:A13)=E2)*B2:B13)}
dabei stehen die Datumswerte im Bereich A2:A13, die Beträge im Bereich B2:B13, das auszuwählende Jahr in E2 und der auszuwählende Monat in D2.
Gruß
Heinz
AW: SUMMEWENN mit Datumsbeschränkung
07.12.2004 08:18:33
Clemens
Super - danke für die schnelle Hilfe!
lg Clemens
Geht übrigens auch mit SUMMEWENN
Boris
Hi Clemens,
=SUMME(SUMMEWENN(A:A;{"&gt31.10.2005"."&gt30.11.2005"};B:B)*{1.-1})
Grüße Boris
AW: Geht übrigens auch mit SUMMEWENN
07.12.2004 08:56:29
Clemens
Ah - geschwungene Klammern sind mein Freund... :)
Kannst Du mir noch ein paar erläuternede Worte dazu spenden - ich muss nämlich gestehen, dass ich das einfach nicht verstehe, warum es funktioniert :) Auf jeden Fall vielen Dank für die Mühe,
lg Clemens
Anzeige
Kurzerläuterung
Boris
Hi Clemens,
die Formel ist nix anderes als
=SUMMEWENN(A:A;"&gt31.10.2005";B:B)-SUMMEWENN(A:A;"&gt30.11.2005";B:B)
Also:
Summiere alle größer 31.10.2005 (also auch alle größer 30.11.2005!) und ziehe anschließend wieder alle größer 30.11.2005 ab.
=SUMME(SUMMEWENN(A:A;{"&gt31.10.2005"."&gt30.11.2005"};B:B)*{1.-1})
Alle größer 31.10.2005 werden in der 2. Matrix mit 1 multipliziert - und alle größer 30.11.2005 mit minus 1. Na ja - und daraus eben die SUMME.
Grüße Boris
http://www.excelformeln.de
AW: Kurzerläuterung
07.12.2004 09:32:17
Clemens
Super - jetzt kenne ich mich aus! Danke!
Ist ein tolles Forum - so schnell hab ich noch nirgends eine Problemlösung bekommen!
lg Clemens
Anzeige

358 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige