Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
140to144
140to144
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Summewenn (Datum)

Summewenn (Datum)
29.07.2002 01:16:37
Klaus
In der Tabelle steht:

A B
1 06.07.2002 1000
2 07.07.2002 2000
3 08.08.2002 3000

5 01.07.2002 31.07.2002 =summewenn(a1:a3;">a5";b1:b3)-
summewenn(a1:a3;">b5";b1:b3)
Das Ergebnis soll 3000 sein. Funktioniert aber nicht. Kann mir jemand helfen? Herzlichen Dank ! Klaus

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Matrix
29.07.2002 01:35:34
Charly
Hi Klaus,
folgende Formel
=SUMME((A1:A3>A5)*(A1:A3>B5)*(B1:B3))
mit Strg+Shift+Return abschließen.
Gruss Charly
Re: Summewenn (Datum)
29.07.2002 01:41:55
Arnim
Hallo Klaus,
ich nehme an, daß Du die Monatszahlen errechnen willst?
Schreibe z.B. in D1 eine 7 (für Juli), in D2 ein 8 (August) usw.
In E1 die Formel:
=SUMMENPRODUKT((MONAT(A$1:A$100)=D1)*B$1:B$100)
und kopiere sie herunter.

Gruß Arnim

...Fehler
29.07.2002 01:53:33
Charly
..sorry Fehler in der ersten Formel
ich hatte es so gelesen, du willst die Summe aus B1:B3
zwischen zwei Datums(Datums, hä - oder wie das heist)
errechnen.
Dann folgende Formel
=SUMMENPRODUKT((A1:A3 > A5)*(A1:A3 < B5)*(B1:B3))
Gruss Charly
Anzeige
Re: ...Fehler
29.07.2002 20:52:23
Klaus
Vielen Dank für die Antwort. Leider bekomme ich den Fehler "Wert".
Ich habe die Formel von Arnim benutzt - =SUMMENPRODUKT((MONAT(A$1:A$100)=D1)*B$1:B$100)
die funktioniert. Ich würde natürlich gerne wissen, woran das liegen kann, damit ich das Ganze etwas besser verstehe. Nochmals herzlichen Dank!
Viele Grüße Klaus
Re: ...Fehler
29.07.2002 21:25:43
Arnim
Hallo Klaus,
beide Formeln von Klaus klappen! Bei der ersten Formel hat er sich nur verschrieben. Er hat, wie Du wolltest, die Daten entsprechend eingetragen. Das Anfangsdatum 01.07.2002 in A5 und Enddatum 31.07.2002 in B5. Dann lautet die erste Formel:

=SUMME((A1:A3>A5)*(A1:A3 < B5)*B1:B3)

Dies ist eine Array-Formel und muß mit den Tasten "Strg"+"Shift(=Umschalt)" und dann erst "Enter" eingegeben werden (Wenn Du die ersten Tasten nicht gedrückt hältst, kommt als Ergebnis "Wert" raus!)
Seine 2. Formel kannst Du (wie meine) nur mit "Enter" eingeben!

Gruß Arnim



Anzeige
Re: ...Fehler
29.07.2002 23:01:15
Klaus
Alles klar. in den Zellen mit den zu berechnenden Werten hatte ich mit Wenn.....;""; den Wert 0 ausgeblendet. Nun funktioniert es. Herzlichen Dank! Klaus

320 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige