Summenprodukt Monat

Bild

Betrifft: Summenprodukt Monat
von: John
Geschrieben am: 17.11.2015 18:27:33

Hallo,
ich habe die Formel

=SUMMENPRODUKT((MONAT([Uebersicht.xlsm]Helper!B2:B5)=A12)*(JAHR([Uebersicht.xlsm]Helper!B2:B5)=E10)  *([Uebersicht.xlsm]Helper!F2:F5))  

A12 ist der Monat zb. 11
E10 ist das Jahr zb. 2015
wenn ich nun von B2:B5 / F2:F5 folgendes mache
B F
2 / 14.11.2015 5
3 / 15.11.2015 10
4 / Leer
5 / Leer
zeigt er mir #Wert!
Lass ich es aber B2:B3 rechnen, geht es...
Es muss doch möglich sein, das er die leeren Ignoriert!?
Ich weiss doch nicht bei Indirekt wieviele Zeilen enthalten sind wenn die anzahl der Datenblätter Variert???
Grüsse John

Bild

Betrifft: AW: Summenprodukt Monat
von: Werner
Geschrieben am: 17.11.2015 18:32:58
Hallo John,
dann einfach ein WENNFEHLER drum rum.
=WENNFEHLER(deine Formel;"")
Gruß Werner

Bild

Betrifft: nonsens!
von: Sepp
Geschrieben am: 17.11.2015 18:34:26
Hallo Werner,
dann erhält er eine leere Zelle, aber nicht das gewünschte Ergebnis!

Gruß Sepp


Bild

Betrifft: AW: nonsens!
von: Werner
Geschrieben am: 17.11.2015 18:45:20
Hallo Sepp,
hast natürlich recht mit deinem nonsens.
Wer lesen kann ist klar im Vorteil. Es muss doch möglich sein, das er die leeren Ignoriert!?
Werner

Bild

Betrifft: AW: Summenprodukt Monat
von: Sepp
Geschrieben am: 17.11.2015 18:33:09
Hallo John,

=SUMMENPRODUKT((MONAT([Uebersicht.xlsm]Helper!B2:B5)=A12)*(JAHR([Uebersicht.xlsm]Helper!B2:B5)=E10) *([Uebersicht.xlsm]Helper!B2:B5)<>"")*[Uebersicht.xlsm]Helper!F2:F5) 
Gruß Sepp


Bild

Betrifft: AW: Summenprodukt Monat
von: John
Geschrieben am: 17.11.2015 18:52:42
Hallo Sepp,
wir sind nah dran...
Exel korrigiert die Formel auf

=SUMMENPRODUKT((MONAT(Helper!B2:B5)=A12)*(JAHR(Helper!B2:B5)=E10)*(Helper!B2:B5)<>"") *Helper!F2:F5
Es wird aber dann immernoch #Wert! angezeigt!
Habe mal zur besseren übersicht das [Uebersicht.xlsm]entfernt ;)
Grüsse John

Bild

Betrifft: siehe mein Beitrag ... owT
von: Matthias L
Geschrieben am: 17.11.2015 18:54:00


Bild

Betrifft: freihändig geschrieben
von: Sepp
Geschrieben am: 17.11.2015 18:57:06
Hallo John,
da ist ein Klammer verrutscht!
statt

=SUMMENPRODUKT((MONAT(Helper!B2:B5)=A12)*(JAHR(Helper!B2:B5)=E10)*(Helper!B2:B5)<>"")  *Helper!F2:F5

mus es so lauten
=SUMMENPRODUKT((MONAT(Helper!B2:B5)=A12)*(JAHR(Helper!B2:B5)=E10)*(Helper!B2:B5<>"") *Helper!F2:F5) 
Gruß Sepp


Bild

Betrifft: AW: freihändig geschrieben
von: John
Geschrieben am: 17.11.2015 19:20:25
Hi Sepp, also ich denke das liegt wie Matthias schon sagte liegt das sicherlich an den Zellen, aber wie zum Teufel!?
Und wenn ich es ohne die Leeren Zeilen angebe funktioniert es ja aber ich weiss doch nicht im Vorraus wieviele ich habe...
Grüsse John

Bild

Betrifft: Beispieldatei? o.T.
von: Sepp
Geschrieben am: 17.11.2015 19:22:37

Gruß Sepp


Bild

Betrifft: AW: Beispieldatei? o.T.
von: John
Geschrieben am: 17.11.2015 19:45:11
Hi Sepp,
wenn ich alles richtig gemacht habe dann sollte die Datei unter https://www.herber.de/bbs/user/101599.xlsm verfügbar sein!
Ich muss jetzt leider los zur Nachtschicht!
Bedanke mich erst mal bei euch beiden und melde mich dann Morgen ;)
Grüsse John

Bild

Betrifft: AW: Beispieldatei? o.T.
von: Sepp
Geschrieben am: 17.11.2015 23:03:53
Hallo John,
https://www.herber.de/bbs/user/101602.xlsm

Gruß Sepp


Bild

Betrifft: AW: Beispieldatei? o.T.
von: John
Geschrieben am: 18.11.2015 07:36:35
Sepp, und alle anderen beteiligten...
IHR SEID SPITZE,
für Sepp terrorisiere ich am frühen Morgen meine lieben Nachbarn mit
"it`s a kind of Magic" Freddy...
Hab schon geglaubt das wird nix, da wird meine Frau sich aber Freuen XD
Grüsse John

Bild

Betrifft: AW: Beispieldatei? o.T.
von: John
Geschrieben am: 18.11.2015 16:24:37
Danke Sepp für die änderung in der Datei...
Ich habe alles angepasst und es funktioniert, es fehlte zwar noch die FileSearchINFO aber ich bin ja nicht auf dem Kopf gefallen ;)
Grüsse John

Bild

Betrifft: AW: Summenprodukt Monat
von: Matthias L
Geschrieben am: 17.11.2015 18:51:19
Hallo
Also bei mir wird kein Fehler angezeigt, auch wenn 2 Daten fehlen
Habs mal nur in der Tabelle gemacht.
Tabelle1

 ABCEF
1     
2 28.11.2015  2
3    3
4 30.11.20156 4
5    5
10   2015 
11     
1211    

Formeln der Tabelle
ZelleFormel
F2=ZEILE()
F3=ZEILE()
C4=SUMMENPRODUKT((MONAT(B2:B5)=A12)*(JAHR(B2:B5)=E10)*(F2:F5))
F4=ZEILE()
F5=ZEILE()


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Sollte ein Fehler angezeigt werden, so ist die Zelle nicht leer, sondernn es ist min. ein Leerzeichen [Space-Taste] gesetzt. Das kannst Du ja mit =Länge(DeineZelle) prüfen
Tabelle1

 BC
4 #WERT!

Formeln der Tabelle
ZelleFormel
C4=SUMMENPRODUKT((MONAT(B2:B5)=A12)*(JAHR(B2:B5)=E10)*(F2:F5))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Prüf also mal die Zellen in Spalte(B), ob sie wirklich leer sind.
Gruß Matthias

Bild

Betrifft: AW: Summenprodukt Monat
von: John
Geschrieben am: 17.11.2015 19:09:32
Hi Matthias,
ich habe deine Formel mal auf dem StartBlatt nachgestellt und sie Funktioniert aber
wenn ich das auf die anderen Felder auf dem Blatt (Helper) definiere kommt nach wie vor #WERT!
in den Tabelen die leer sind ist kein Leerzeichen nur eine formel welche mir die werte mit Indirekt holt

=WENNFEHLER(WENN(ISTLEER(INDIREKT(A3&"!E14"));"";INDIREKT(A3&"!E14"));"")
Grüsse John

Bild

Betrifft: Das liegt einfach daran, dass die Fmln in ...
von: Luc:-?
Geschrieben am: 17.11.2015 19:55:55
Helper Leer-Strings für LeerZellen eintragen, John;
das sind dann Texte, die zwar für SUMMENPRODUKT kein Problem darstellen, wohl aber für MONAT und JAHR! Diese Fktt liefern dann einen F-Wert, den du ebenfalls abfangen müsstest. Oder du lässt die Fmln in Helper in diesen Fällen eine 0 ausgeben, was zwar als Monat Januar liefern würde, aber als Jahr 1900, was somit also eigentlich kein Problem sein sollte (es sei denn, du verarbeitest Daten von 1/1900 ;-]).
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: AW: Summenprodukt Monat
von: Josef B
Geschrieben am: 17.11.2015 19:43:07
Hallo John
Versuche das so:
=SUMMENPRODUKT((MONAT([Uebersicht.xlsm]Helper!B2:B5)=A12)*(JAHR([Uebersicht.xlsm]Helper!B2:B5)=E10); [Uebersicht.xlsm]Helper!F2:F5)
Gruss Sepp

Bild

Betrifft: Das wird mit LeerStrings nichts, Sepp! ;-] orT
von: Luc:-?
Geschrieben am: 17.11.2015 19:57:29
Gruß, Luc :-?

Besser informiert mit …

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Werte einer Zelle durch #-Zeichen ersetzen"