Microsoft Excel

Herbers Excel/VBA-Archiv

KFZ Zulassungsjahr und -Monat durch die kennzeich

Betrifft: KFZ Zulassungsjahr und -Monat durch die kennzeich von: Grosso
Geschrieben am: 13.08.2004 13:46:31

Hallo Leute,

Ich brauche eure dringende Hilfe. Schau bitte mal die tabelle an, und lass euch nicht stoeren, "ANO" heisst JAHR auf portugiesisch und "Primeira matricula do mês" heisst "Die erste zugelassene KFZ-kennzeichen des Monates", OK !.

Die Tabelle lass sich auf einem ungekannte grund nicht uploaden und so musst ich einem printscreen auf word anlegen:

https://www.herber.de/bbs/user/9591.doc

Die kennzeichen in Portugal werden die reihe nach vergeben, erst die vier nummer und dann die Buchstaben.

Was ich braeuchte waere folgendes, ich habe eine liste mit 3000 kennzeichen und soll, mit hilfe der tabelle, das Zullassungsmonat und Zullassungsjahr, schnell mit einem funktion bestimmen.

Habt ihr einem idee, wie mann das locker hinkriegen kann ?

Liebe gruessen aus Portugal.

Vitor Grosso

  


Betrifft: AW: KFZ Zulassungsjahr und -Monat durch die kennzeich von: Bertram
Geschrieben am: 13.08.2004 14:56:58

Hallo Grosso,

schau dir das mal an: https://www.herber.de/bbs/user/9595.xls

Wenn du in Zelle B17 deine Nummer eingibst, sollte darunter Monat und Jahr erscheinen.

Gruß
Bertram


  


Betrifft: AW: KFZ Zulassungsjahr und -Monat durch die kennzeich von: GerdZ
Geschrieben am: 13.08.2004 15:52:57

Hallo,

am einfachsten wird es sein, wenn Du diese Matrix in eine Liste änderst und dabei die Kennzeichen für die Suche umdrehst, zuerst die Buchstaben dann die Ziffern. In Tabelle2 steht dann z.B.:
Kennz.	Jahr	Monat
AA0001	1992	Mrz
AD6086	1992	Apr
HA8807	1992	Mai
AL9429	1992	Jun
usw.
Dein gesuchtes Kennzeichen (z.B. 9457CP) steht in A1, das Jahr erhälst Du dann mit:
=SVERWEIS(RECHTS(A1;2)&LINKS(A1;4);Tabelle2!A:C;3;WAHR)
und den Monat mit:
=SVERWEIS(RECHTS(A1;2)&LINKS(A1;4);Tabelle2!A:C;2;WAHR)

Gruß
Gerd


 

Beiträge aus den Excel-Beispielen zum Thema "KFZ Zulassungsjahr und -Monat durch die kennzeich "