Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
192to196
192to196
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Datum im folgenden Monat?

Datum im folgenden Monat?
18.12.2002 16:38:18
Götz Kroeber
Hallo,

ich möchte bei einem Datum herausfinden, ob es sich bei dem Monat dieses Datums um den Folgemonat - bezogen auf das heutige Datum - handelt!

Zum Beispiel: Wenn das Datum 27.01.2003 im folgenden Monat liegt, dann gib mir ein "Ja" heraus!

Vielen Dank für die Hilfe!
Götz

16
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: Datum im folgenden Monat?
18.12.2002 16:47:43
L.Vira
Formel oder VBA?
Re: Datum im folgenden Monat?
18.12.2002 16:49:25
Götz Kroeber
Formel, bitte!
Re: Datum im folgenden Monat?
18.12.2002 16:58:36
L.Vira
warte bis die Formelexperten zuschlagen.
noch offen
18.12.2002 16:59:12
L.Vira
oT
Re: Datum im folgenden Monat?
18.12.2002 17:07:22
Hajo_Zi
Re: Datum im folgenden Monat?
18.12.2002 17:18:27
Götz K
Hallo Hajo,

in Zelle A1 soll aber nicht ein Datum mit aktuellem, sondern zukünftigem Monat stehen (z.B. 12.01.2003 oder 03.02.2003). Wenn bei diesen Datumswerten der Monat dem nächsten oder übernächsten Monat entspricht (immer bezogen auf das aktuelle Datum), dann soll in Zelle B1 "JA" stehen.

Hast Du noch einen Tipp?

Gruß
Götz

Re: Datum im folgenden Monat?
18.12.2002 17:22:00
Hajo_Zi
Hallo Götz

das Datum war nur ein Beispiel. Bisher stand immer Folgemonat, jetzt sind es schon zwei.

Mein Frage
"brauchts Du die genaue Information das es der Folgemonat ist"

sehe ich noch nicht beantwortet. Was angezeigt wird ist doch Schall und Rach das ist doch sofort geändert, wenn die Worte in der Formel geändert werden.

Gruß Hajo

Anzeige
Re: Datum im folgenden Monat?
18.12.2002 17:24:57
Götz K
Hallo Hajo,

ja, ich brauche die genaue Information, das es der Folgemonat ist!

Gruß
Götz

Re: Datum im folgenden Monat?
18.12.2002 17:34:50
Hajo_Zi
Re: Datum im folgenden Monat?
18.12.2002 17:40:03
Boris
Hallo miteinander,

ich hab auch mal ne Lösung gebastelt:


Re: noch offen
18.12.2002 18:06:41
andre
hallo,
etwa so - datum in d1:
=WENN(MONAT(HEUTE())=MONAT(D1)-1;"ja";"nein")
wenn der jahreswechsell eine rolle spielt:
fragen
gruss andre
Das ist ja grade der Clou...
18.12.2002 20:21:22
Boris
an der Sache...
Umsonst sind die bisherigen Vorschläge nicht so lang geworden...;-)))

Gruß Boris

Re: Das ist ja grade der Clou...
18.12.2002 20:53:12
andre
... war wohl auf dem rechten auge blind '-(
hab nur den linken verlauf für voll genommen.
gruss andre
möchte meinen "Senf" auch dazugeben
18.12.2002 22:26:22
Panicman
Hallo Götz,

vielleicht auch so:

C1 =WENN((MONAT(B1)+JAHR(B1)*12)-(MONAT($A$1)+JAHR($A$1)*12)=0;"aktueller Monat";TEXT((MONAT(B1)+JAHR(B1)*12)-(MONAT($A$1)+JAHR($A$1)*12)&" Monat(e) später";"@"))

Den Text kannste ja nach deinen Bedürfnissen anpassen

Tschüß
Holger

Anzeige
Re: Datum im folgenden Monat?
20.12.2002 08:29:55
Götz K
Hallo Hajo,

sorry, bin jetzt erst wieder zurück. Deine Formeln sind großartig! Genau so etwas habe ich gesucht!

Danke und Gruß
Götz

Re: noch offen
20.12.2002 08:34:25
Götz K
Hallo Andre,

der Datumswechsel spielt unbedingt eine Rolle! Habe dafür eine Lösung von Hajo bekommen.

Dennoch vielen Dank für die Mühe!

Gruß
Götz

309 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige